summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-01-11 02:53:22 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-01-11 20:17:03 -0500
commitd75a0cd98649c610c8c6ed05011233a49af156e9 (patch)
tree6a5079b300df476a8d338aa690cb9d17d3fe50bd
parent7bd000d104f79f2b1c51c48c9d01f247189f9935 (diff)
downloadpatches-base-for-series-2558.tar
patches-base-for-series-2558.tar.gz
* gnu/packages/audio.scm (audacity): Update to 2.3.3. [source](snippet): Remove bundled "lame". [arguments]: Adjust "use-upstream-headers" phase. * gnu/packages/patches/audacity-build-with-system-portaudio.patch: Adjust patch.
-rw-r--r--gnu/packages/audio.scm9
-rw-r--r--gnu/packages/patches/audacity-build-with-system-portaudio.patch16
2 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 9312dcc113..247a415307 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -332,7 +332,7 @@ engineers, musicians, soundtrack editors and composers.")
(define-public audacity
(package
(name "audacity")
- (version "2.3.2")
+ (version "2.3.3")
(source
(origin
(method git-fetch)
@@ -342,7 +342,7 @@ engineers, musicians, soundtrack editors and composers.")
(file-name (git-file-name name version))
(sha256
(base32
- "08w96124vv8k4myd4vifq73ningq6404x889wvg2sk016kc4dfv1"))
+ "0707fsnrl4vjalsi21w4blwgz024qhd0w8rdd5j5vpxf5lyk2rbk"))
(patches (search-patches "audacity-build-with-system-portaudio.patch"))
(modules '((guix build utils)))
(snippet
@@ -351,7 +351,7 @@ engineers, musicians, soundtrack editors and composers.")
(for-each
(lambda (dir)
(delete-file-recursively (string-append "lib-src/" dir)))
- '("expat" "ffmpeg" "libflac" "libid3tag" "libmad" "libogg"
+ '("expat" "ffmpeg" "lame" "libflac" "libid3tag" "libmad" "libogg"
"libsndfile" "libsoxr" "libvamp" "libvorbis" "lv2"
"portaudio-v19" "portmidi" "soundtouch" "twolame"
;; FIXME: these libraries have not been packaged yet:
@@ -451,7 +451,8 @@ engineers, musicians, soundtrack editors and composers.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* '("src/NoteTrack.cpp"
"src/AudioIO.cpp"
- "src/AudioIO.h")
+ "src/AudioIO.h"
+ "src/AudioIOBase.cpp")
(("../lib-src/portmidi/pm_common/portmidi.h") "portmidi.h")
(("../lib-src/portmidi/porttime/porttime.h") "porttime.h"))
(substitute* "src/prefs/MidiIOPrefs.cpp"
diff --git a/gnu/packages/patches/audacity-build-with-system-portaudio.patch b/gnu/packages/patches/audacity-build-with-system-portaudio.patch
index 3b73a6c930..05325a1493 100644
--- a/gnu/packages/patches/audacity-build-with-system-portaudio.patch
+++ b/gnu/packages/patches/audacity-build-with-system-portaudio.patch
@@ -1,6 +1,8 @@
Downloaded from here:
https://sourceforge.net/p/audacity/mailman/message/36106562/
+Modified for use on later versions of audacity.
+
>From 5f9482a191359f2c477763a36d2c865c5f186602 Mon Sep 17 00:00:00 2001
From: Antonio Ospite <ao2@ao2.it>
Date: Tue, 7 Nov 2017 13:06:33 +0100
@@ -31,16 +33,16 @@ over the code where it's used.
1 file changed, 16 insertions(+), 1 deletion(-)
diff --git a/src/AudioIO.cpp b/src/AudioIO.cpp
-index a78bd1cab..d5481838d 100644
+index 48715869c..bb4bf472c 100644
--- a/src/AudioIO.cpp
+++ b/src/AudioIO.cpp
-@@ -452,8 +452,23 @@ writing audio.
+@@ -480,9 +480,22 @@ time warp info and AudioIOListener and whether the playback is looped.
#define ROUND(x) (int) ((x)+0.5)
//#include <string.h>
- #include "../lib-src/portmidi/pm_common/portmidi.h"
+ // #include "../lib-src/portmidi/pm_common/portmidi.h"
- #include "../lib-src/portaudio-v19/src/common/pa_util.h"
#include "NoteTrack.h"
-+
+ #endif
+PaTime PaUtil_GetTime( void )
+{
+#ifdef HAVE_MACH_ABSOLUTE_TIME
@@ -55,10 +57,6 @@ index a78bd1cab..d5481838d 100644
+ return (PaTime) tv.tv_usec * 1e-6 + tv.tv_sec;
+#endif
+}
-+
- #endif
#ifdef EXPERIMENTAL_AUTOMATED_INPUT_LEVEL_ADJUSTMENT
---
-2.15.0
-
+ #define LOWER_BOUND 0.0