summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/audacity-build-with-system-portaudio.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/audacity-build-with-system-portaudio.patch')
-rw-r--r--gnu/packages/patches/audacity-build-with-system-portaudio.patch16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/patches/audacity-build-with-system-portaudio.patch b/gnu/packages/patches/audacity-build-with-system-portaudio.patch
index 3b73a6c930..05325a1493 100644
--- a/gnu/packages/patches/audacity-build-with-system-portaudio.patch
+++ b/gnu/packages/patches/audacity-build-with-system-portaudio.patch
@@ -1,6 +1,8 @@
Downloaded from here:
https://sourceforge.net/p/audacity/mailman/message/36106562/
+Modified for use on later versions of audacity.
+
>From 5f9482a191359f2c477763a36d2c865c5f186602 Mon Sep 17 00:00:00 2001
From: Antonio Ospite <ao2@ao2.it>
Date: Tue, 7 Nov 2017 13:06:33 +0100
@@ -31,16 +33,16 @@ over the code where it's used.
1 file changed, 16 insertions(+), 1 deletion(-)
diff --git a/src/AudioIO.cpp b/src/AudioIO.cpp
-index a78bd1cab..d5481838d 100644
+index 48715869c..bb4bf472c 100644
--- a/src/AudioIO.cpp
+++ b/src/AudioIO.cpp
-@@ -452,8 +452,23 @@ writing audio.
+@@ -480,9 +480,22 @@ time warp info and AudioIOListener and whether the playback is looped.
#define ROUND(x) (int) ((x)+0.5)
//#include <string.h>
- #include "../lib-src/portmidi/pm_common/portmidi.h"
+ // #include "../lib-src/portmidi/pm_common/portmidi.h"
- #include "../lib-src/portaudio-v19/src/common/pa_util.h"
#include "NoteTrack.h"
-+
+ #endif
+PaTime PaUtil_GetTime( void )
+{
+#ifdef HAVE_MACH_ABSOLUTE_TIME
@@ -55,10 +57,6 @@ index a78bd1cab..d5481838d 100644
+ return (PaTime) tv.tv_usec * 1e-6 + tv.tv_sec;
+#endif
+}
-+
- #endif
#ifdef EXPERIMENTAL_AUTOMATED_INPUT_LEVEL_ADJUSTMENT
---
-2.15.0
-
+ #define LOWER_BOUND 0.0