aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c3e8e4d6ec..aea0f4c764 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8122,17 +8122,19 @@ Python.")
(define-public python-azure-storage-blob
(package
(name "python-azure-storage-blob")
- (version "12.12.0")
+ (version "12.22.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "azure-storage-blob" version ".zip"))
+ (uri (pypi-uri "azure-storage-blob" version))
(sha256
- (base32 "1xv23ph822qywjxs81say9xi5dzmvxcii6sww6d1hvd83iyz1npn"))))
- (build-system python-build-system)
+ (base32 "0vkkngiybx5372j9vc9p4wn6hakpv99l0ipsf4kw7ccazss4p05k"))))
+ (build-system pyproject-build-system)
(propagated-inputs
- (list python-azure-core python-cryptography python-msrest))
- (native-inputs (list unzip))
+ (list python-azure-core
+ python-cryptography
+ python-isodate
+ python-typing-extensions))
(home-page "https://github.com/Azure/azure-sdk-for-python/")
(synopsis "Microsoft Azure Blob Storage client library for Python")
(description "This package provides the Microsoft Azure Blob Storage