aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-09-12 19:21:23 +0200
committerChristopher Baines <mail@cbaines.net>2024-09-15 10:21:42 +0100
commit17c4c3449bae97943ddfca55d0b1f1a47034d15d (patch)
treeb10b509faf289b67b869de4b9f696d771d8e0874 /gnu
parentd085fcf49372a369affad0745d4c891fc6e665ea (diff)
downloadguix-17c4c3449bae97943ddfca55d0b1f1a47034d15d.tar
guix-17c4c3449bae97943ddfca55d0b1f1a47034d15d.tar.gz
gnu: python-azure-storage-blob: Update to 12.22.0.
* gnu/packages/python-web.scm (python-azure-storage-blob): Update to 12.22.0. [build-system]: Move to pyproject-build-system. [propagated-inputs]: Remove python-msrest. Add python-isodate and python-typing-extensions. Change-Id: If7163dd4568136a19799b78e9fce246ab0611cbd Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c3e8e4d6ec..aea0f4c764 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8122,17 +8122,19 @@ Python.")
(define-public python-azure-storage-blob
(package
(name "python-azure-storage-blob")
- (version "12.12.0")
+ (version "12.22.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "azure-storage-blob" version ".zip"))
+ (uri (pypi-uri "azure-storage-blob" version))
(sha256
- (base32 "1xv23ph822qywjxs81say9xi5dzmvxcii6sww6d1hvd83iyz1npn"))))
- (build-system python-build-system)
+ (base32 "0vkkngiybx5372j9vc9p4wn6hakpv99l0ipsf4kw7ccazss4p05k"))))
+ (build-system pyproject-build-system)
(propagated-inputs
- (list python-azure-core python-cryptography python-msrest))
- (native-inputs (list unzip))
+ (list python-azure-core
+ python-cryptography
+ python-isodate
+ python-typing-extensions))
(home-page "https://github.com/Azure/azure-sdk-for-python/")
(synopsis "Microsoft Azure Blob Storage client library for Python")
(description "This package provides the Microsoft Azure Blob Storage