aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e23f3f33fa..47d958f1ae 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1917,17 +1917,17 @@ confidence to have in an alignment.")
(delete-file-recursively ".git")))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ;no "check" target
+ `(#:tests? #f ;no "check" target
#:make-flags
- (list (string-append "ZLIB="
- (assoc-ref %build-inputs "zlib:static")
- "/lib/libz.a")
- (string-append "LDFLAGS="
- (string-join '("-lboost_filesystem"
- "-lboost_system"
- "-lboost_iostreams"
- "-lz"
- "-fopenmp"))))
+ ,#~(list (string-append "ZLIB="
+ #$(this-package-input "zlib")
+ "/lib/libz.so")
+ (string-append "LDFLAGS="
+ (string-join '("-lboost_filesystem"
+ "-lboost_system"
+ "-lboost_iostreams"
+ "-lz"
+ "-fopenmp"))))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'do-not-build-bundled-pigz
@@ -1959,7 +1959,6 @@ confidence to have in an alignment.")
("boost" ,boost)
("sparsehash" ,sparsehash)
("pigz" ,pigz)
- ("zlib:static" ,zlib "static")
("zlib" ,zlib)))
(supported-systems '("x86_64-linux"))
(home-page "https://sourceforge.net/p/bless-ec/wiki/Home/")