aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index b204280317..547e8a0811 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2272,6 +2272,37 @@ part of @url{https://github.com/pion, Pion} WebRTC implementation.")
packetizer and depacketizer.")
(license license:expat)))
+(define-public go-github-com-pion-sctp
+ (package
+ (name "go-github-com-pion-sctp")
+ (version "1.8.19")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/sctp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19yzpyrlmk3gvpkpn5846rad9cc8ffxw9jqwnpr6szqax7k0l0zw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/pion/sctp"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-pion-logging
+ go-github-com-pion-randutil
+ go-github-com-pion-transport-v3))
+ (home-page "https://github.com/pion/sctp")
+ (synopsis "Implementation of SCTP in Golang")
+ (description
+ "This package implements the @acronym{Stream Control Transmission
+Protocol,SCTP} as specified in
+@uref{https://rfc-editor.org/rfc/rfc9260.html,RFC 9260}.")
+ (license license:expat)))
+
(define-public go-github-com-pion-stun
(package
(name "go-github-com-pion-stun")