aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 33f9b703a7..6b6b05c4a0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4025,6 +4025,11 @@ you are running, what theme or icon set you are using, etc.")
(delete 'configure)
(add-before 'build 'patch-source-paths
(lambda _
+ (substitute* "fetch.c"
+ (("grep")
+ #$(file-append grep "/bin/grep"))
+ (("awk")
+ #$(file-append gawk "/bin/awk")))
(substitute* "uwufetch.c"
(("(/usr(/local)?)(.*;)" all _ _ rest)
(string-append #$output rest)))))
@@ -4033,6 +4038,8 @@ you are running, what theme or icon set you are using, etc.")
(lambda _
(mkdir-p (string-append #$output "/include")))))))
(inputs (list lshw
+ gawk
+ grep
;; viu XXX not yet packaged in Guix
xwininfo))
(home-page "https://github.com/TheDarkBug/uwufetch")