aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm6
-rw-r--r--gnu/packages/patches/rust-rspec-1-remove-clippy.patch16
2 files changed, 19 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8d9cde1e9a..a278fde74b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -65217,12 +65217,12 @@ can handle huge texts and memory-incoherent edits with ease.")
(uri (crate-uri "rspec" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "02hfwxqjdc39ygnjysvn5qz343fahmwm16rxvxayh403d5y9wf49"))))
+ (base32 "02hfwxqjdc39ygnjysvn5qz343fahmwm16rxvxayh403d5y9wf49"))
+ (patches (search-patches "rust-rspec-1-remove-clippy.patch"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
- (("rust-clippy" ,rust-clippy-0.0.153)
- ("rust-colored" ,rust-colored-2)
+ (("rust-colored" ,rust-colored-2)
("rust-derive-new" ,rust-derive-new-0.5)
("rust-derive-builder" ,rust-derive-builder-0.9)
("rust-expectest" ,rust-expectest-0.12)
diff --git a/gnu/packages/patches/rust-rspec-1-remove-clippy.patch b/gnu/packages/patches/rust-rspec-1-remove-clippy.patch
new file mode 100644
index 0000000000..46c994f7ee
--- /dev/null
+++ b/gnu/packages/patches/rust-rspec-1-remove-clippy.patch
@@ -0,0 +1,16 @@
+Remove the dependency on clippy
+
+diff --git a/Cargo.toml b/Cargo.toml
+index 177cb80..7260c34 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -39,9 +39,6 @@ version = "1.5"
+
+ [dependencies.time]
+ version = "0.2"
+-[build-dependencies.clippy]
+-version = "0.0.153"
+-optional = true
+
+ [features]
+ default = []