aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a3b9799209..cb0f479a3f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9563,11 +9563,10 @@ like switching to windows and launching applications.")
`(#:glib-or-gtk? #t)) ; To wrap binaries and/or compile schemas
(native-inputs
(append
- ;; GJS depends on Rust, which is x86_64-only so far, so remove the GJS
- ;; dependency on other platforms (FIXME).
- (if (target-x86-64?)
- (list gjs)
- '())
+ ;; GJS depends on Rust so remove the GJS dependency on other platforms.
+ (if (supported-package? gjs)
+ (list gjs)
+ '())
(list gettext-minimal
`(,glib "bin")
gobject-introspection