aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm83
1 files changed, 74 insertions, 9 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index da5ca76e10..032e2577ab 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -59,6 +59,7 @@
;;; Copyright © 2022 Tobias Kortkamp <tobias.kortkamp@gmail.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
;;; Copyright © 2023 Jake Leporte <jakeleporte@outlook.com>
+;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -132,6 +133,8 @@
#:use-module (gnu packages polkit)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages python-web)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages qt)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages syncthing)
@@ -140,6 +143,8 @@
#:use-module (gnu packages tcl)
#:use-module (gnu packages terminals)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages wm)
+ #:use-module (gnu packages webkit)
#:use-module (gnu packages xorg)
#:use-module (gnu packages)
#:use-module (ice-9 match))
@@ -1816,6 +1821,66 @@ but can also follow a growing file, display contents, delete entries and more.")
connectivity of the X server running on a particular @code{DISPLAY}.")
(license license:gpl3+)))
+(define-public ulauncher
+ (package
+ (name "ulauncher")
+ (version "6.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Ulauncher/Ulauncher")
+ (commit "1e68d47473f8e77d375cb4eca644c3cda68ed7e9")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1c2czlrsf5aq8c88qliqbnqvf04q9cnjc1j6hivqa0w260mzjll1"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-libX11
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "ulauncher/utils/xinit.py"
+ (("libX11.so.6")
+ (search-input-file inputs "/lib/libX11.so")))))
+ (add-after 'unpack 'fix-usr
+ (lambda _
+ (substitute* "setup.py"
+ (("\\{sys.prefix\\}")
+ (string-append #$output)))))
+ (add-after 'unpack 'fix-os-release
+ (lambda _
+ (define (touch file)
+ (call-with-output-file file
+ (const #t)))
+ (let* ((hard-path "/etc/os-release")
+ (fixed-path (string-append #$output
+ hard-path)))
+ ;; Make it relative
+ ;; Update hardcoded path to something
+ ;; within the build enviroment.
+ (substitute* "ulauncher/utils/environment.py"
+ ((hard-path)
+ fixed-path))
+ ;; Create directory for the dummy file.
+ (mkdir-p (string-append #$output "/etc"))
+ (touch fixed-path))))
+ (add-before 'check 'env-setup
+ ;; The test require access to home to put temporary files.
+ (lambda _
+ (setenv "HOME"
+ (getcwd)))))))
+ (native-inputs (list intltool python-distutils-extra python-mock))
+ (inputs (list libx11 python-levenshtein python-pycairo))
+ (propagated-inputs (list keybinder libwnck gsettings-desktop-schemas
+ python-pygobject webkitgtk-with-libsoup2))
+ (home-page "https://ulauncher.io")
+ (synopsis "Application launcher for Linux")
+ (description
+ "Ulauncher is a fast application launcher for Linux. It is written in
+Python, using GTK+, and features: App Search (fuzzy matching), Calculator,
+Extensions, Shortcuts, File browser mode and Custom Color Themes.")
+ (license license:gpl3+)))
+
(define-public rofi
(package
(name "rofi")
@@ -1875,7 +1940,7 @@ by name.")
(package
(inherit rofi)
(name "rofi-wayland")
- (version "1.7.5+wayland1")
+ (version "1.7.5+wayland2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/lbonn/rofi"
@@ -1883,16 +1948,16 @@ by name.")
"/rofi-" version ".tar.xz"))
(sha256
(base32
- "09n71wv3nxpzpjmvqmxlxk0zfln3x2l8admfq571781p9hw0w6wp"))))
+ "0l6rf8qwvawyh938pinl9fkwzjnq72xpa9a7lwk9jrr5lkk3h8yj"))))
(build-system meson-build-system)
(inputs
(modify-inputs (package-inputs base)
(append wayland wayland-protocols)))
(description
- (string-append
- (package-description base)
- " This package, @code{rofi-wayland}, provides additional wayland
-support.")))))
+ "Rofi is a minimalist application launcher. It memorizes which
+applications you regularly use and also allows you to search for an
+application by name. This package, @code{rofi-wayland}, provides additional
+wayland support."))))
(define-public rofi-calc
(package
@@ -2583,7 +2648,7 @@ Wayland and @code{wlroots} by leveraging @command{grim} and @command{slurp}.")
(define-public wl-clipboard
(package
(name "wl-clipboard")
- (version "2.1.0")
+ (version "2.2.0")
(source
(origin
(method git-fetch)
@@ -2592,7 +2657,7 @@ Wayland and @code{wlroots} by leveraging @command{grim} and @command{slurp}.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1g6hcsn4klapvz3bw0k8syixwyyi4cl1c7vbc6f1a2hjpcf4pawn"))))
+ (base32 "0r45k6fk9k26qs88s2sjlgjjamhj2jqghdivlh2xjqknws63d29g"))))
(build-system meson-build-system)
(arguments
(list #:configure-flags
@@ -2605,7 +2670,7 @@ Wayland and @code{wlroots} by leveraging @command{grim} and @command{slurp}.")
(add-after 'unpack 'patch-file-names
(lambda* (#:key inputs #:allow-other-keys)
(substitute* (find-files "src" "\\.c$")
- (("\"(cat|rm)\"" _ command)
+ (("\"(cat)\"" _ command)
(string-append "\"" (assoc-ref inputs "coreutils")
"/bin/" command "\""))
(("\"xdg-mime\"")