aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 55838314db..c656101159 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -208,6 +208,7 @@ the leaves of a full binary tree.")
xterm
xsetroot
libx11
+ libxcursor
libxext
libxfixes
libxinerama
@@ -224,6 +225,10 @@ the leaves of a full binary tree.")
(string-append "-DBASHCOMPLETIONDIR=" out "/etc/bash_completion.d")))
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'link-libxcursor
+ (lambda _
+ ;; libX11 will dlopen libXcursor to load cursors.
+ (setenv "LDFLAGS" "-lXcursor")))
(add-after 'install 'install-xsession
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))