aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm93
1 files changed, 91 insertions, 2 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index b5e9dca524..4068dbe5d4 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -70,6 +70,8 @@
;;; Copyright © 2024 Ahmad Draidi <a.r.draidi@redscript.org>
;;; Copyright © 2024 chris <chris@bumblehead.com>
;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
+;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1803,6 +1805,52 @@ modules for building a Wayland compositor.")
(sha256
(base32 "00s73nhi3sc48l426jdlqwpclg41kx1hv0yk4yxhbzw19gqpfm1h"))))))
+(define-public wl-mirror
+ (package
+ (name "wl-mirror")
+ (version "0.16.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Ferdi265/wl-mirror")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jdycr9vf5skbf55kbm2hc3zl3qg58x3bb6xqkf9qx14m4ramcdj"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f ;No tests.
+ #:configure-flags
+ #~(list "-DINSTALL_DOCUMENTATION=ON"
+ (string-append "-DWL_PROTOCOL_DIR="
+ #$(this-package-input "wayland-protocols")
+ "/share/wayland-protocols")
+ (string-append "-DWLR_PROTOCOL_DIR="
+ #$(this-package-input "wlr-protocols")
+ "/share/wlr-protocols"))))
+ (inputs (list egl-wayland mesa wayland wayland-protocols wlr-protocols))
+ (native-inputs (list pkg-config scdoc))
+ (home-page "https://github.com/Ferdi265/wl-mirror")
+ (synopsis "Simple Wayland output mirror client")
+ (description
+ "This package provides @command{wl-mirror}, a solution to @code{sway}'s
+lack of output mirroring by mirroring an output onto a client surface. It has
+the following features:
+
+@itemize
+@item Mirror an output onto a resizable window.
+@item Mirror an output onto another output by fullscreening the window.
+@item React to changes in output scale (including fractional scaling).
+@item Preserve aspect ratio.
+@item Correct flipped or rotated outputs.
+@item Custom flips or rotations.
+@item Mirror custom regions of outputs.
+@item Receive additional options on stdin for changing the mirrored screen or
+region on the fly.
+@end itemize")
+ (license license:gpl3)))
+
(define-public wmenu
(package
(name "wmenu")
@@ -2165,7 +2213,7 @@ compository, supporting the following featuers:
(define-public waybar
(package
(name "waybar")
- (version "0.10.0")
+ (version "0.10.2")
(source
(origin
(method git-fetch)
@@ -2174,7 +2222,7 @@ compository, supporting the following featuers:
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "00a8npilvcvicn9mff00i5rdzdll0zrmq0y8wgr314gnljn52md7"))))
+ (base32 "0h8anmzhbimgdjnbg79al32d5acbfyrh3sf8wcsbx1296qpd6af6"))))
(build-system meson-build-system)
(arguments
(list #:configure-flags #~(list "--wrap-mode=nodownload")))
@@ -2543,6 +2591,23 @@ productive, customizable lisp based systems.")
control module for StumpWM.")
(license license:gpl3))))
+(define-public sbcl-stumpwm-binwarp
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-binwarp")
+ (arguments
+ '(#:asd-systems '("binwarp")
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "util/binwarp"))))))
+ (home-page "https://github.com/stumpwm/stumpwm-contrib")
+ (synopsis "Keyboard-driven divide-and-conquer mouse control mode")
+ (description "This package provides a keyboard-driven divide-and-conquer
+mouse control mode for StumpWM.")
+ (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
+
(define-public sbcl-stumpwm-ttf-fonts
(package
(inherit stumpwm-contrib)
@@ -3767,6 +3832,30 @@ notable features include:
It is inspired by dwm and xmonad.")
(license license:expat))))
+(define-public wsbg
+ (let ((commit "15b0d0f6910ea97b9bcc471695fac07270955dd2")
+ (revision "0")
+ ;; Upstream has no version tags, but meson.build contains the correct
+ ;; version number.
+ (version "0.1.0"))
+ (package
+ (inherit swaybg)
+ (name "wsbg")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/saibier/wsbg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15xrnwp54kghigx06y4qmmn1q9f26fx4cawyl4kcbqrrzfbbj1g6"))))
+ (home-page "https://github.com/saibier/wsbg")
+ (synopsis "Workspace wallpaper tool for Sway")
+ (description "Wallpaper utility for Sway with support for per-workspace
+configuration."))))
+
(define-public yambar-wayland
(package
(name "yambar-wayland")