aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm30
1 files changed, 28 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 4d526fce0c..6c3329ffb6 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -235,8 +235,9 @@ data.")
(version "0.12")
(source (origin
(method url-fetch)
- (uri (string-append "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
- version ".tar.gz"))
+ (uri (string-append
+ "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
+ version ".tar.gz"))
(sha256
(base32
"0gwzic3ifg2d0w32ya3agpxh8i083cgvf7kmc51cnbgqnfr02300"))
@@ -2977,3 +2978,28 @@ directory.")
various contexts including the R console, R Markdown documents, and Shiny web
applications.")
(license l:expat)))
+
+(define-public r-curl
+ (package
+ (name "r-curl")
+ (version "0.9.3")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "curl" version))
+ (sha256
+ (base32
+ "02p9s1jlk8dcbvn71ivn4xnrqh9dwqyhgn4s1fzcfmnmfxhl5gld"))))
+ (build-system r-build-system)
+ (inputs
+ `(("libcurl" ,curl)))
+ (home-page "https://github.com/jeroenooms/curl")
+ (synopsis "HTTP client for R")
+ (description
+ "The @code{curl()} and @code{curl_download()} functions provide highly
+configurable drop-in replacements for base @code{url()} and
+@code{download.file()} with better performance, support for encryption, gzip
+compression, authentication, and other @code{libcurl} goodies. The core of
+the package implements a framework for performing fully customized requests
+where data can be processed either in memory, on disk, or streaming via the
+callback or connection interfaces.")
+ (license l:expat)))