aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 42a15340ea..8310df7097 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
+;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -405,7 +406,7 @@ designed to encode video or images into an H.265 / HEVC encoded bitstream.")
(define-public libass
(package
(name "libass")
- (version "0.13.7")
+ (version "0.14.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -413,11 +414,11 @@ designed to encode video or images into an H.265 / HEVC encoded bitstream.")
version "/libass-" version ".tar.xz"))
(sha256
(base32
- "17byv926w1mxn56n896sxvdq4m0yv1l7qbm688h6zr3nzgsyarbh"))))
+ "18iqznl4mabhj9ywfsz4kwvbsplcv1jjxq50nxssvbj8my1267w8"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
- ("yasm" ,yasm)))
+ ("nasm" ,nasm)))
(propagated-inputs
`(("freetype" ,freetype)
("fribidi" ,fribidi)
@@ -1006,7 +1007,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
`(("perl" ,perl) ; for zsh completion file
("pkg-config" ,pkg-config)
("python-docutils" ,python-docutils)))
- ;; Missing features: libguess, Wayland, V4L2
+ ;; Missing features: libguess, V4L2
(inputs
`(("alsa-lib" ,alsa-lib)
("enca" ,enca)
@@ -1038,6 +1039,8 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
("pulseaudio" ,pulseaudio)
("rsound" ,rsound)
("waf" ,python-waf)
+ ("wayland" ,wayland)
+ ("libxkbcommon", libxkbcommon)
("youtube-dl" ,youtube-dl)
("zlib" ,zlib)))
(arguments