aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm60
1 files changed, 44 insertions, 16 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 00072055d3..2e7ba6d10e 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2365,7 +2365,7 @@ input files is possible, including video files.")
(define-public vlc
(package
(name "vlc")
- (version "3.0.18")
+ (version "3.0.20")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2374,7 +2374,7 @@ input files is possible, including video files.")
"/vlc-" version ".tar.xz"))
(sha256
(base32
- "1v7db9icrb12yz7banq2wvpjpvqfrj031yj1kf5smn35qcwl82ap"))))
+ "1d99p93k8d86bbanym6b6jii1aiavb570lpb83gws8979mdjiixd"))))
(build-system gnu-build-system)
(native-inputs
(list flex bison gettext-minimal pkg-config))
@@ -3799,7 +3799,7 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(define-public mlt
(package
(name "mlt")
- (version "7.22.0")
+ (version "7.24.0")
(source
(origin
(method git-fetch)
@@ -3808,7 +3808,7 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1aa23kni64751x0kd54lr87ns9kdc8pblhqp8m8608ah8xwak4mw"))))
+ (base32 "08fgcf20v4q52lfdwzvscbbppa6m582f551q6fzxz2vs5936w3wx"))))
(build-system cmake-build-system)
(arguments
(list
@@ -3965,7 +3965,7 @@ be used for realtime video capture via Linux-specific APIs.")
(define-public obs
(package
(name "obs")
- (version "29.0.2")
+ (version "29.1.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3975,7 +3975,7 @@ be used for realtime video capture via Linux-specific APIs.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ijn19wy52fa7ahr29v1rzvh6j0qr7i5xl129m6s9c644f7i51ac"))
+ "192p7m3g8ynbkq3s894w6a0w6gix3k237q5jwqrrr8idwfwwyh0g"))
(patches
(search-patches "obs-modules-location.patch"))))
(build-system cmake-build-system)
@@ -4013,6 +4013,7 @@ be used for realtime video capture via Linux-specific APIs.")
(inputs
(list
alsa-lib
+ asio
bash-minimal
curl
eudev
@@ -4030,6 +4031,7 @@ be used for realtime video capture via Linux-specific APIs.")
luajit
mbedtls-lts
mesa
+ nlohmann-json
pciutils
pipewire
pulseaudio
@@ -4043,6 +4045,7 @@ be used for realtime video capture via Linux-specific APIs.")
vlc
wayland
wayland-protocols
+ websocketpp
zlib))
(synopsis "Live streaming software")
(description "Open Broadcaster Software provides a graphical interface for
@@ -4153,6 +4156,35 @@ your host privately.")
inputs and applications using PipeWire.")
(license license:gpl2+)))
+(define-public obs-source-record
+ (package
+ (name "obs-source-record")
+ (version "0.3.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/exeldro/obs-source-record")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07yglklrjn3nkyw8755nwchcfgvyw7d0n4qynvja8s7rgqbbs0an"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests
+ #:configure-flags
+ #~(list (string-append "-DLIBOBS_INCLUDE_DIR="
+ #$(this-package-input "obs") "/lib")
+ "-DBUILD_OUT_OF_TREE=On"
+ "-Wno-dev")))
+ (inputs (list obs))
+ (home-page "https://github.com/exeldro/obs-source-record")
+ (synopsis "OBS plugin for recording sources via a filter")
+ (description "This package provides an OBS plugin for recording sources
+via a filter.")
+ (license license:gpl2)))
+
(define-public obs-websocket
;; Functionality was merged into OBS.
(deprecated-package "obs-websocket" obs))
@@ -5764,10 +5796,10 @@ to convenience of translating and batch processing of multiple documents.")
(license license:gpl3+)))
(define-public theorafile
- (let ((commit "404b14d7602b5918d117eaa64e8aa6601ede8593"))
+ (let ((commit "ea5fd6d34053ff72b0abe83fa4f2cd0771d92663"))
(package
(name "theorafile")
- (version (git-version "0.0.0" "1" commit))
+ (version (git-version "0.0.0" "2" commit))
(source
(origin
(method git-fetch)
@@ -5776,23 +5808,19 @@ to convenience of translating and batch processing of multiple documents.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "128c3pjzqbgrj020glm5jd6ss18vl19471lj615w2brjwb7c1f0z"))))
+ (base32 "0affdbs7vhi7apj5sc5mg815vqy1913zgymx3m1rsz8fhrcg3bvn"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags '("CC=gcc")
+ `(#:make-flags '(,(string-append "CC=" (cc-for-target)))
+ #:test-target "test"
#:phases
(modify-phases %standard-phases
(delete 'configure)
- (replace 'check
- (lambda _
- (setenv "CC" "gcc")
- (invoke "make" "test")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(install-file "libtheorafile.so" (string-append out "/lib"))
- (install-file "theorafile.h" (string-append out "/include")))
- #t)))))
+ (install-file "theorafile.h" (string-append out "/include"))))))))
(native-inputs
;; For tests.
(list sdl2))