aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm36
1 files changed, 24 insertions, 12 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 0c7c496c82..c01eb9decd 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2017, 2020 EuAndreh <eu@euandre.org>
;;; Copyright © 2017, 2018, 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
-;;; Copyright © 2017, 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2017, 2020, 2024 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2018 Timothy Sample <samplet@ngyro.com>
@@ -1131,8 +1131,8 @@ collaboration using typical untrusted file hosts or services.")
(license license:gpl3+)))
(define-public cgit
- (let ((commit "8905003cba637e5b18069e625cd4f4c05ac30251")
- (rev "2"))
+ (let ((commit "dbadd856ba0537110338cfe58256b152d01388c0")
+ (rev "3"))
(package
(name "cgit")
;; Update the ‘git-source’ input as well.
@@ -1144,7 +1144,7 @@ collaboration using typical untrusted file hosts or services.")
(commit commit)))
(sha256
(base32
- "1ha8d2n59mv89vv4bqgg3dk82n1rqh8kd8y654vqx7v1v7m645qz"))
+ "1r9mafmjgi3hknv88a1ypym6qvy2qzs1i3n6z22ddg8q4sb1wjvk"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -1220,9 +1220,9 @@ collaboration using typical untrusted file hosts or services.")
(method url-fetch)
;; cgit is tightly bound to git. Use GIT_VER from the Makefile,
;; which may not match the current (package-version git).
- (uri "mirror://kernel.org/software/scm/git/git-2.44.0.tar.xz")
+ (uri "mirror://kernel.org/software/scm/git/git-2.45.0.tar.xz")
(sha256
- (base32 "1qqxd3pdsca6m93lxxkz9s06xs1sq0ah02lhrr0a6pjvrf6p6n73"))))
+ (base32 "0a9ljpjypszj9cxq5lk9zq8bq9v87h9fn9ph3zgyfxk4s05j1b0a"))))
("bash-minimal" ,bash-minimal)
("openssl" ,openssl)
("python" ,python)
@@ -3158,7 +3158,7 @@ be served with a HTTP file server of your choice.")
(define-public gource
(package
(name "gource")
- (version "0.51")
+ (version "0.54")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3166,15 +3166,26 @@ be served with a HTTP file server of your choice.")
"/gource-" version "/gource-" version ".tar.gz"))
(sha256
(base32
- "16p7b1x4r0915w883lp374jcdqqja37fnb7m8vnsfnl2n64gi8qr"))))
+ "1rgsssff5ygafc5svg19p046r4h2q9a3wqqbzrllvkyjcpgwxjqx"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
(list (string-append "--with-boost-libdir="
(assoc-ref %build-inputs "boost")
- "/lib"))))
+ "/lib")
+ "--with-tinyxml")
+ #:disallowed-references (,tzdata-for-tests)
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'unbundle
+ (lambda _
+ (delete-file-recursively "src/tinyxml")))
+ (add-before 'check 'check-setup
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "TZDIR" ; for src/test/datetime_tests.cpp
+ (search-input-directory inputs
+ "share/zoneinfo")))))))
(native-inputs
- (list pkg-config))
+ (list pkg-config tzdata-for-tests))
(inputs
(list boost
ftgl
@@ -3183,8 +3194,9 @@ be served with a HTTP file server of your choice.")
glu
libpng
mesa
- pcre
- (sdl-union (list sdl2 sdl2-image))))
+ pcre2
+ (sdl-union (list sdl2 sdl2-image))
+ tinyxml))
(home-page "https://gource.io/")
(synopsis "3D visualisation tool for source control repositories")
(description "@code{gource} provides a software version control