aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 14 insertions, 10 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7648a948e0..a824546fee 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5961,19 +5961,21 @@ and a new version of @code{g-brief}.")
(define-deprecated-package texlive-latex-g-brief texlive-g-brief)
-(define-public texlive-latex-galois
+(define-public texlive-galois
(package
- (name "texlive-latex-galois")
+ (name "texlive-galois")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "galois"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0d4l0msk8j5pi95xnmm9wygv1vbpkwkv5amx9l0km86cs79jpp1h"))))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/galois/"
+ "source/latex/galois/"
+ "tex/latex/galois/")
+ (base32
+ "1324nw1r1aj6khz6fvrhd1p1sinadrd83j0s2q2fhnsgwp6sw94f")))
+ (outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments '(#:tex-directory "latex/galois"))
+ (propagated-inputs
+ (list texlive-graphics))
(home-page "https://www.ctan.org/pkg/galois")
(synopsis "Typeset Galois connections")
(description
@@ -5981,6 +5983,8 @@ and a new version of @code{g-brief}.")
in colour.")
(license license:lppl)))
+(define-deprecated-package texlive-latex-galois texlive-galois)
+
(define-public texlive-latex-gcite
(package
(name "texlive-latex-gcite")