aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 08b974bc1c..69cf1231ba 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -44770,8 +44770,16 @@ other configuration can be extensively customized.")
"18xxivpgjdh8v6kg0b45zjv18sm9a4ljpwk6a4cghg5l5yggrjcx")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments (list #:link-scripts #~(list "texdoctk.pl")))
- (inputs (list perl))
+ (arguments
+ (list
+ #:link-scripts #~(list "texdoctk.pl")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'link-scripts 'wrap-perl-script
+ (lambda _
+ (wrap-program (string-append #$output "/bin/texdoctk")
+ `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))))))
+ (inputs (list perl perl-tk))
(propagated-inputs (list texlive-kpathsea))
(home-page "https://ctan.org/pkg/texdoctk")
(synopsis "Easy access to package documentation")