aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm29
1 files changed, 2 insertions, 27 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 5222354e74..92eda1c9b1 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -30,7 +30,7 @@
(define-public syncthing
(package
(name "syncthing")
- (version "0.14.54")
+ (version "1.0.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/syncthing/syncthing"
@@ -38,7 +38,7 @@
"/syncthing-source-v" version ".tar.gz"))
(sha256
(base32
- "1pfjckwsrhy8lbmy42fawgh1gcfmjbh3dfxx05w5yjxnpd1g2z6r"))
+ "0992nsdiw374pbh1dywg7c2jijzy4xmsv0b7q5p76xn2yyg5yhr7"))
;; Since the update to Go 1.11, Go programs have been keeping
;; spurious references to all their dependencies:
;; <https://bugs.gnu.org/33620>.
@@ -366,31 +366,6 @@ database/sql package.")
(home-page "https://github.com/lib/pq")
(license expat))))
-(define-public go-github-com-minio-sha256-simd
- (let ((commit "ad98a36ba0da87206e3378c556abbfeaeaa98668")
- (revision "1"))
- (package
- (name "go-github-com-minio-sha256-simd")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/minio/sha256-simd")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0yfnqn3kqdnlfm54yvc4fr5vpdmwdi2kw571nlkbpmy8ldhsqqfi"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/minio/sha256-simd"))
- (synopsis "Hardware-accelerated SHA256 in Go using SIMD")
- (description "This packages provides a pure Go implementation of SHA256
-using SIMD (Single instruction, multiple data) instructions for Intel and ARM
-architectures.")
- (home-page "https://github.com/minio/sha256-simd")
- (license asl2.0))))
-
(define-public go-github-com-oschwald-geoip2-golang
(package
(name "go-github-com-oschwald-geoip2-golang")