aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm103
1 files changed, 26 insertions, 77 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 366a5f0ebb..7269e91ec0 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -213,29 +213,6 @@ notification area icon for Syncthing. Supported Syncthing features:
(define-public qsyncthingtray
(deprecated-package "qsyncthingtray" syncthing-gtk))
-(define-public go-github-com-jackpal-go-nat-pmp
- (package
- (name "go-github-com-jackpal-go-nat-pmp")
- (version "1.0.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jackpal/go-nat-pmp")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1p2yrzfbkazc9nisr2iqjwzhb6q16zj6finyxxn2ikk7iiighl1g"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/jackpal/go-nat-pmp"))
- (synopsis "Port mapping and discovery of external IP address")
- (description "This package provides a Go client for the NAT-PMP internet
-protocol for port mapping and discovering the external IP address of a
-firewall.")
- (home-page "https://github.com/jackpal/go-nat-pmp")
- (license asl2.0)))
-
(define-public go-github-com-audriusbutkevicius-recli
(package
(name "go-github-com-audriusbutkevicius-recli")
@@ -450,34 +427,6 @@ run-time in Go.")
(home-page "https://github.com/sasha-s/go-deadlock")
(license asl2.0)))
-(define-public go-github-com-syndtr-goleveldb
- (let ((commit "758128399b1df3a87e92df6c26c1d2063da8fabe")
- (revision "4"))
- (package
- (name "go-github-com-syndtr-goleveldb")
- (version (git-version "1.0.1" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/syndtr/goleveldb")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0mnkzrz4di13g6ggd54my7bkb9nwk8f5k672dyasn467wsg7bf8f"))))
- (build-system go-build-system)
- (propagated-inputs
- (list go-github-com-golang-snappy))
- (arguments
- `(#:import-path "github.com/syndtr/goleveldb/leveldb"
- #:unpack-path "github.com/syndtr/goleveldb"
- #:tests? #f)) ; XXX needs 'github.com/onsi/gomega' package
- (synopsis "LevelDB key/value database")
- (description "This is an implementation of the LevelDB key / value
-database in Go.")
- (home-page "https://github.com/syndtr/goleveldb")
- (license bsd-2))))
-
(define-public go-github-com-thejerf-suture
(package
(name "go-github-com-thejerf-suture")
@@ -611,34 +560,34 @@ notification library in Go.")
(license expat))))
(define-public go-github-com-matttproud-golang-protobuf-extensions-pbutil
- (let ((commit "c12348ce28de40eed0136aa2b644d0ee0650e56c")
- (revision "0"))
- (package
- (name "go-github-com-matttproud-golang-protobuf-extensions-pbutil")
- (version (git-version "1.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/matttproud/golang_protobuf_extensions")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1d0c1isd2lk9pnfq2nk0aih356j30k3h1gi2w0ixsivi5csl7jya"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/matttproud/golang_protobuf_extensions/pbutil"
- #:unpack-path "github.com/matttproud/golang_protobuf_extensions"))
- (propagated-inputs
- (list go-github-com-golang-protobuf-proto))
- (synopsis "Streaming Protocol Buffers in Go")
- (description "This package provides various Protocol Buffer
+ (package
+ (name "go-github-com-matttproud-golang-protobuf-extensions-pbutil")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/matttproud/golang_protobuf_extensions")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jw4vjycwx0a82yvixmp25805krdyqd960y8lnyggllb6br0vh41"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/matttproud/golang_protobuf_extensions/v2/pbutil"
+ #:unpack-path "github.com/matttproud/golang_protobuf_extensions/v2"))
+ (propagated-inputs
+ (list go-github-com-golang-protobuf-proto
+ go-google-golang-org-protobuf))
+ (synopsis "Streaming Protocol Buffers in Go")
+ (description "This package provides various Protocol Buffer
extensions for the Go language, namely support for record length-delimited
message streaming.")
- (home-page "https://github.com/matttproud/golang_protobuf_extensions")
- (license asl2.0))))
+ (home-page "https://github.com/matttproud/golang_protobuf_extensions")
+ (license asl2.0)))
(define-public go-github-com-go-asn1-ber-asn1-ber
(package