aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm202
1 files changed, 194 insertions, 8 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 9a4cdd219d..b09076106f 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2021 Lars-Dominik Braun <lars@6xq.net>
+;;; Copyright © 2021 Frank Pursel <frank.pursel@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -68,6 +69,7 @@
#:use-module (gnu packages machine-learning)
#:use-module (gnu packages maths)
#:use-module (gnu packages multiprecision)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -75,6 +77,7 @@
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages shells)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages ssh)
#:use-module (gnu packages tcl)
@@ -3228,7 +3231,7 @@ using the multicore functionality of the parallel package.")
("https://cdn.datatables.net/1.10.20/js/dataTables.semanticui.js"
"1477f49xyxs4phias789mbspv23w8alxchhl5b5iy0aw6vd35c43"
"datatables")
-
+
("https://cdn.datatables.net/autofill/2.3.4/js/dataTables.autoFill.js"
"04i6n7r3512gzfihl5wnhrvm0klnjp41g1z6cny3j803hvmnp8zk"
"datatables-extensions/AutoFill")
@@ -3307,7 +3310,7 @@ using the multicore functionality of the parallel package.")
("https://cdn.datatables.net/colreorder/1.5.2/js/colReorder.jqueryui.js"
"1rd8hijz3prg2y36fvqczrpdzixibjy2dxgs2fmgr8wrm8k01rrm"
"datatables-extensions/ColReorder")
-
+
("https://cdn.datatables.net/fixedcolumns/3.3.0/js/dataTables.fixedColumns.js"
"0vsqk2fv59n351bdfcbvhmvpq38qwf41j1cn810xz1l1i07cg4hg"
"datatables-extensions/FixedColumns")
@@ -3326,7 +3329,7 @@ using the multicore functionality of the parallel package.")
("https://cdn.datatables.net/fixedcolumns/3.3.0/js/fixedColumns.semanticui.js"
"1kqsap9y0d25a7m5zjakipifl5qi2qr72kfj4ap3zxavd8md2wyn"
"datatables-extensions/FixedColumns")
-
+
("https://cdn.datatables.net/fixedheader/3.1.6/js/dataTables.fixedHeader.js"
"1ml5ilnm8nirr6rsgmzn75l1k0hcjz3sqk6h1y1gy8cpwpklvqri"
"datatables-extensions/FixedHeader")
@@ -3345,7 +3348,7 @@ using the multicore functionality of the parallel package.")
("https://cdn.datatables.net/fixedheader/3.1.6/js/fixedHeader.semanticui.js"
"1v0i6dc68h8l8673fb5970igzkl7as36riv504iyg82glfi7n877"
"datatables-extensions/FixedHeader")
-
+
("https://cdn.datatables.net/keytable/2.5.1/js/dataTables.keyTable.js"
"16iib2icxsjh93x5hd42gpsl7bzpcsqb7zjgj0m1s02ls45bdlv5"
"datatables-extensions/KeyTable")
@@ -3383,7 +3386,7 @@ using the multicore functionality of the parallel package.")
("https://cdn.datatables.net/responsive/2.2.3/js/responsive.bootstrap4.js"
"1zjh15p7n1038sggaxv1xvcwbkhw2nk1ndx745s6cxiqb69y3i0h"
"datatables-extensions/Responsive")
-
+
("https://cdn.datatables.net/rowgroup/1.1.1/js/dataTables.rowGroup.js"
"0s4q7ir2d6q36g29nn9mqk7vrqrdig2mm5zbcv0sn2lixqi29pkj"
"datatables-extensions/RowGroup")
@@ -3421,7 +3424,7 @@ using the multicore functionality of the parallel package.")
("https://cdn.datatables.net/rowreorder/1.2.6/js/rowReorder.semanticui.js"
"1zjrx2rlgw3qannsqa88pcp3i4pc87pwv7rmgfw1dar8namkr9kk"
"datatables-extensions/RowReorder")
-
+
("https://cdn.datatables.net/scroller/2.0.1/js/dataTables.scroller.js"
"0zfjjdvwwlsnps24i9l4c97hmway2qs6addks1is5bxl4k1r6d16"
"datatables-extensions/Scroller")
@@ -3440,7 +3443,7 @@ using the multicore functionality of the parallel package.")
("https://cdn.datatables.net/scroller/2.0.1/js/scroller.semanticui.js"
"1dfbblbzbryjgiv31qfdjnijz19lmyijg12win3y8gsgfd4fp9zz"
"datatables-extensions/Scroller")
-
+
("https://cdn.datatables.net/searchbuilder/1.0.0/js/dataTables.searchBuilder.js"
"0n5g0j0yfzqvdpsmwb27bj1rd8zx864fsx2k7b2kpv6mqqavzpqc"
"datatables-extensions/SearchBuilder")
@@ -3475,7 +3478,7 @@ using the multicore functionality of the parallel package.")
("https://cdn.datatables.net/searchpanes/1.1.1/js/searchPanes.semanticui.js"
"1781d0xmx7xz0jly0wsw2zbrdmfc1crahmcdbsfbj5s66kdsnd7c"
"datatables-extensions/SearchPanes")
-
+
("https://cdn.datatables.net/select/1.3.1/js/dataTables.select.js"
"0a7bkbz1cizhiq4h417b4rcdr7998pn8q4dlyzx8449xdp0h0n0v"
"datatables-extensions/Select")
@@ -6690,3 +6693,186 @@ original Datasaurus is detailed in \"Same Stats, Different Graphs: Generating
Datasets with Varied Appearance and Identical Statistics through Simulated
Annealing\" @url{doi:10.1145/3025453.3025912}.")
(license license:expat)))
+
+(define-public r-lmom
+ (package
+ (name "r-lmom")
+ (version "2.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "lmom" version))
+ (sha256
+ (base32 "1lnj41gynaar5isyijg5nbll64qdxa12dnqvz7lxhaclqcjskqna"))))
+ (properties `((upstream-name . "lmom")))
+ (build-system r-build-system)
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "https://cran.r-project.org/package=lmom")
+ (synopsis "L-Moments for R")
+ (description
+ "This package provides functions related to L-moments: computation
+of L-moments and trimmed L-moments of distributions and data samples;
+parameter estimation; L-moment ratio diagram; plot vs. quantiles of an
+extreme-value distribution.")
+ (license license:cpl1.0)))
+
+(define-public r-gld
+ (package
+ (name "r-gld")
+ (version "2.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gld" version))
+ (sha256
+ (base32 "1wrw7i5bq7rb2ahadm57y9fmr697r7lp9ln7ajcd592b0nn60n4i"))))
+ (properties `((upstream-name . "gld")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-e1071" ,r-e1071) ("r-lmom" ,r-lmom)))
+ (home-page
+ "https://cran.r-project.org/package=gld")
+ (synopsis
+ "Estimation and Use of the Generalised (Tukey) Lambda Distribution")
+ (description
+ "The generalised lambda distribution, or Tukey lambda distribution,
+provides a wide variety of shapes with one functional form. This package
+provides random numbers, quantiles, probabilities, densities and
+density quantiles for four different types of the distribution, the FKML
+(Freimer et al 1988), RS (Ramberg and Schmeiser 1974), GPD (van Staden
+and Loots 2009) and FM5 - see documentation for details. It provides the
+density function, distribution function, and Quantile-Quantile plots.
+It implements a variety of estimation methods for the distribution,
+including diagnostic plots. Estimation methods include the starship (all
+4 types), method of L-Moments for the GPD and FKML types, and a number
+of methods for only the FKML type. These include maximum likelihood,
+maximum product of spacings, Titterington's method, Moments, Trimmed
+L-Moments and Distributional Least Absolutes.")
+ (license license:gpl2+)))
+
+(define-public r-exact
+ (package
+ (name "r-exact")
+ (version "3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Exact" version))
+ (sha256
+ (base32 "0acm01njg3arlzwknv5v1sdsz5ab0bdh04sn1bmf91hcg3li8qd7"))))
+ (properties `((upstream-name . "Exact")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-rootsolve" ,r-rootsolve)))
+ (home-page "https://cran.r-project.org/package=Exact")
+ (synopsis "Unconditional Exact Test")
+ (description
+ "Performs unconditional exact tests and power calculations for 2x2
+contingency tables. For comparing two independent proportions, performs
+@url{doi:10.1038/156177a0, Barnard's test (1945)} using the original CSM
+test (@url{doi:10.1093/biomet/34.1-2.123, Barnard (1947)}), using Fisher's
+p-value referred to as @url{doi:10.1111/j.1467-9574.1970.tb00104.x,
+Boschloo's test (1970)}, or using a Z-statistic (@url{doi:10.2307/2981892,
+Suissa and Shuster (1985)}). For comparing two binary proportions,
+performs unconditional exact test using McNemar's Z-statistic
+(@url{doi:10.1191/0962280203sm312ra, Berger and Sidik (2003)}), using
+McNemar's Z-statistic with continuity correction, or using CSM test.
+Calculates confidence intervals for the difference in proportion.")
+ (license license:gpl2)))
+
+(define-public r-desctools
+ (package
+ (name "r-desctools")
+ (version "0.99.43")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "DescTools" version))
+ (sha256
+ (base32 "1zx4wwry7pph21q37r0r1vgx616pki232ych2wl9z2s2fmclwg4c"))))
+ (properties `((upstream-name . "DescTools")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bh" ,r-bh)
+ ("r-boot" ,r-boot)
+ ("r-data-table" ,r-data-table)
+ ("r-exact" ,r-exact)
+ ("r-expm" ,r-expm)
+ ("r-gld" ,r-gld)
+ ("r-mass" ,r-mass)
+ ("r-mvtnorm" ,r-mvtnorm)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rstudioapi" ,r-rstudioapi)))
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "https://andrisignorell.github.io/DescTools/")
+ (synopsis "Tools for Descriptive Statistics")
+ (description
+ "This package provides a collection of miscellaneous basic statistic
+functions and convenience wrappers for efficiently describing data.
+The author's intention was to create a toolbox, which facilitates the
+(notoriously time consuming) first descriptive tasks in data analysis,
+consisting of calculating descriptive statistics, drawing graphical
+summaries and reporting the results. The package contains furthermore
+functions to produce documents using MS Word (or PowerPoint) and functions
+to import data from Excel. Many of the included functions can be found
+scattered in other packages and other sources written partly by Titans
+of R. The reason for collecting them here, was primarily to have them
+consolidated in ONE instead of dozens of packages (which themselves might
+depend on other packages which are not needed at all), and to provide a
+common and consistent interface as far as function and arguments naming,
+NA handling, recycling rules etc. are concerned. Google style guides
+were used as naming rules (in absence of convincing alternatives).
+The BigCamelCase style was consequently applied to functions borrowed
+from contributed R packages as well.")
+ (license license:gpl2+)))
+
+(define-public xlispstat
+ (let ((commit "f1bea6053df658ee48612bf1f63c35de99e2c649")
+ (revision "0"))
+ (package
+ (name "xlispstat")
+ (version (git-version "3.52.23" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jhbadger/xlispstat.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1p0cmgy19kbkxia139cb5w9dnkp2cdqp5n3baag6cq3prn3n71mf"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:parallel-build? #f ; Parallel builds are not supported
+ #:configure-flags (list "--with-gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-output-to-file "exit.lsp"
+ (lambda () (display "(exit)")))
+ (invoke "./xlisp" "tests/test" "exit")))))))
+ (inputs `(("tcsh" ,tcsh)
+ ("libx11" ,libx11)
+ ("libxmu" ,libxmu)
+ ("libxext" ,libxext)
+ ("libxpm" ,libxpm)
+ ("libxaw" ,libxaw)
+ ("ncurses" ,ncurses)
+ ("gnuplot" ,gnuplot)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (synopsis "Statistical analysis environment with interactive graphics")
+ (description "XLISP-STAT is a statistical environment based on a Lisp
+dialect called XLISP. To facilitate statistical computations, standard
+functions for addition, logarithms, etc., have been modified to operate on
+lists and arrays of numbers, and a number of basic statistical functions have
+been added. Many of these functions have been written in Lisp, and additional
+functions can be added easily by a user. Several basic forms of plots,
+including histograms, scatterplots, rotatable plots and scatterplot matrices
+are provided. These plots support various forms of interactive highlighting
+operations and can be linked so points highlighted in one plot will be
+highlighted in all linked plots. Interactions with the plots are controlled
+by the mouse, menus and dialog boxes. An object-oriented programming system
+is used to allow menus, dialogs, and the response to mouse actions to be
+ customized.")
+ (home-page "http://homepage.divms.uiowa.edu/~luke/xls/xlsinfo/")
+ (license license:expat))))