aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/rdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rdf.scm')
-rw-r--r--gnu/packages/rdf.scm39
1 files changed, 0 insertions, 39 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 3063ff5887..cc6b009f14 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -367,45 +367,6 @@ powerful language for representing information.")
(license (license:non-copyleft "file://LICENSE"
"See LICENSE in the distribution."))))
-(define-public python-rdflib-5
- (package
- (inherit python-rdflib)
- (version "5.0.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "rdflib" version))
- (sha256
- (base32
- "0mdi7xh4zcr3ngqwlgqdqf0i5bxghwfddyxdng1zwpiqkpa9s53q"))))
- ;; XXX: Lazily disable tests because they require a lot of work
- ;; and this package is only transitional.
- (arguments '(#:tests? #f))))
-
-;; Note: This package is only needed for rdflib < 6.0; supersede when
-;; the above are removed.
-(define-public python-rdflib-jsonld
- (package
- (name "python-rdflib-jsonld")
- (version "0.6.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "rdflib-jsonld" version))
- (sha256
- (base32
- "0qrshlqzv5g5bign7kjja3xf7hyk7xgayr3yd0qlqda1kl0x6z0h"))))
- (build-system python-build-system)
- (native-inputs
- (list python-nose))
- (propagated-inputs
- (list python-rdflib))
- (home-page "https://github.com/RDFLib/rdflib-jsonld")
- (synopsis "rdflib extension adding JSON-LD parser and serializer")
- (description "This package provides an rdflib extension adding JSON-LD
-parser and serializer.")
- (license license:bsd-3)))
-
(define-public python-cfgraph
(package
(name "python-cfgraph")