aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm57
1 files changed, 56 insertions, 1 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index f34511b352..2f258b0364 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2017, 2018, 2019, 2020, 2022 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019, 2020 Christopher Howard <christopher@librehacker.com>
;;; Copyright © 2019, 2020 Evan Straw <evan.straw99@gmail.com>
-;;; Copyright © 2020, 2021, 2022, 2023 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020-2024 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2020 Charlie Ritter <chewzerita@posteo.net>
;;; Copyright © 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -99,12 +99,14 @@
#:use-module (gnu packages sdl)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sphinx)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages swig)
#:use-module (gnu packages tcl)
#:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
#:use-module (gnu packages video)
+ #:use-module (gnu packages web)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
@@ -1890,6 +1892,59 @@ their position, altitude, speed, etc.")
(home-page "https://github.com/flightaware/dump1090")
(license license:gpl2+)))
+(define-public libacars
+ (package
+ (name "libacars")
+ (version "2.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/szpajder/libacars")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08cadcqzhl3i7hpd8jwph33kx52vdwbrj1rlagwrkwb2mfw6szfs"))))
+ (build-system cmake-build-system)
+ (inputs (list jansson libxml2 zlib))
+ (arguments (list #:tests? #f)) ; No test suite
+ (synopsis "Decoder for ACARS messages")
+ (description "This package provides a library for decoding the contents of
+ACARS messages used by planes.")
+ (home-page "https://github.com/szpajder/libacars")
+ (license (list license:bsd-2
+ license:expat))))
+
+(define-public dumpvdl2
+ (package
+ (name "dumpvdl2")
+ (version "2.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/szpajder/dumpvdl2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zxv24fg2ciy7bfiqhx95v0h8b1bnbs3ax06n9ywsssbf4ndas4n"))))
+ (build-system cmake-build-system)
+ (native-inputs (list pkg-config))
+ (inputs
+ (list glib
+ libacars
+ protobuf-c
+ rtl-sdr
+ soapysdr
+ sqlite
+ zeromq))
+ (arguments (list #:tests? #f)) ; No test suite
+ (synopsis "VDL Mode 2 message decoder")
+ (description "This package provides a decoder for VDL Mode 2 messages used
+by planes.")
+ (home-page "https://github.com/szpajder/dumpvdl2")
+ (license license:gpl3+)))
+
(define-public rtl-433
(package
(name "rtl-433")