aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm43
1 files changed, 41 insertions, 2 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 9df49d7fb3..5866d33394 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2360,7 +2360,7 @@ control equipment. The module provides both QML and C++ interfaces. The
primary target audience are embedded devices with fullscreen user interfaces,
and mobile applications targeting TV-like form factors.")))
-(define-public qtscxml
+(define-public qtscxml-5
(package
(inherit qtsvg-5)
(name "qtscxml")
@@ -2388,6 +2388,45 @@ machines (loading the SCXML file and instantiating states and transitions) and
generating a C++ file that has a class implementing the state machine. It
also contains functionality to support data models and executable content.")))
+(define-public qtscxml
+ (package
+ (name "qtscxml")
+ (version "6.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (qt-url name version))
+ (sha256
+ (base32
+ "1jxx9p7zi40r990ky991xd43mv6i8hdpnj2fhl7sf4q9fpng4c58"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "tests/3rdparty")))))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'check) ;move after the install phase
+ (add-after 'install 'check
+ (assoc-ref %standard-phases 'check))
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "ARGS" "-E tst_scion")
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "QML2_IMPORT_PATH"
+ (string-append #$output "/lib/qt6/qml:"
+ (getenv "QML2_IMPORT_PATH"))))))))
+ (build-system cmake-build-system)
+ (inputs (list qtbase qtdeclarative libxkbcommon))
+ (synopsis "Qt SCXML module")
+ (description "The Qt SCXML module provides functionality to create state
+machines from SCXML files. This includes both dynamically creating state
+machines (loading the SCXML file and instantiating states and transitions) and
+generating a C++ file that has a class implementing the state machine. It
+also contains functionality to support data models and executable content.")
+ (home-page (package-home-page qtbase))
+ (license (package-license qtbase))))
+
(define-public qtpositioning
(package
(name "qtpositioning")
@@ -4497,7 +4536,7 @@ color-related widgets.")
qtquickcontrols-5
qtquickcontrols2-5
qtscript
- qtscxml
+ qtscxml-5
qtsensors
qtspeech
qtsvg-5