aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 13aadc8190..1416c3a36c 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -398,7 +398,8 @@ applications on Wayland.")
(file-name (git-file-name name version))
(sha256
(base32 "1ipnkdi8wgv519mvwa5zxlz20wipbypyfixjv2qdfd9vl1pznwvs"))
- (patches (search-patches "grantlee-fix-i586-precision.patch"))))
+ (patches (search-patches "grantlee-fix-i586-precision.patch"
+ "grantlee-register-metaenumvariable.patch"))))
(native-inputs
;; Optional: lcov and cccc, both are for code coverage
(list doxygen))
@@ -898,6 +899,9 @@ tst_qt_cmake_create.cpp"
;; TODO: when core-updates is merged, check again.
"tst_selftests"
+ ;; The 'tst_qsqlthread' test sometimes fails.
+ "tst_qsqlthread"
+
;; The 'tst_qsystemsemaphore' test sometimes fails.
"tst_qsystemsemaphore"
;; The 'tst_moc' test fails with "'fi.exists()' returned FALSE".