aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm66
1 files changed, 25 insertions, 41 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 21f47ceea5..13f54fcc5d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -296,21 +296,6 @@ Qt. Some of its features include:
@end itemize")
(license (list license:gpl2 license:gpl3)))) ;dual-licensed
-(define-public kddockwidgets-1
- (package
- (inherit kddockwidgets)
- (name "kddockwidgets")
- (version "1.7.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/KDAB/KDDockWidgets")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0bz08f1fv3qbza101q0q0w70nd67z3h6azs5wr3ypmva9kvfg4ck"))))))
-
(define-public kvantum
(package
(name "kvantum")
@@ -413,7 +398,8 @@ applications on Wayland.")
(file-name (git-file-name name version))
(sha256
(base32 "1ipnkdi8wgv519mvwa5zxlz20wipbypyfixjv2qdfd9vl1pznwvs"))
- (patches (search-patches "grantlee-fix-i586-precision.patch"))))
+ (patches (search-patches "grantlee-fix-i586-precision.patch"
+ "grantlee-register-metaenumvariable.patch"))))
(native-inputs
;; Optional: lcov and cccc, both are for code coverage
(list doxygen))
@@ -5096,33 +5082,31 @@ configurable also via HTTP.")
(license license:gpl3+)))
(define-public soqt
- (let ((commit-ref "fb8f655632bb9c9c60e0ff9fa69a5ba22d3ff99d")
- (revision "1"))
- (package
- (name "soqt")
- (version (git-version "1.6.0" revision commit-ref))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/coin3d/soqt")
- (commit commit-ref)
- (recursive? #t)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "16vikb3fy8rmk10sg5g0gy2c343hi3x7zccsga90ssnkzpq6m032"))))
- (build-system cmake-build-system)
- (arguments '(#:tests? #f)) ; There are no tests
- (native-inputs
- (list pkg-config cmake))
- (inputs
- (list qtbase-5 coin3d))
- (home-page "https://github.com/coin3d/soqt")
- (synopsis "Qt GUI component toolkit library for Coin")
- (description "SoQt is a Qt GUI component toolkit library for Coin. It is
+ (package
+ (name "soqt")
+ (version "1.6.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/coin3d/soqt")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rsfc4wmghl9fr4bwh9rpzjwzsmx00k4ki5gyvy85nb4kbmr9dwv"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ; There are no tests
+ (native-inputs
+ (list pkg-config cmake))
+ (inputs
+ (list qtbase-5 coin3d))
+ (home-page "https://github.com/coin3d/soqt")
+ (synopsis "Qt GUI component toolkit library for Coin")
+ (description "SoQt is a Qt GUI component toolkit library for Coin. It is
also compatible with SGI and TGS Open Inventor, and the API is based on the API
of the InventorXt GUI component toolkit.")
- (license license:bsd-3))))
+ (license license:bsd-3)))
(define-public libdbusmenu-qt
(package