aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index fc01fc4b83..5a532f8460 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -63,6 +63,7 @@
;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2024 normally_js <normally_js@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3422,6 +3423,24 @@ verification of the SSL peer.")
(home-page "https://github.com/cedadev/ndg_httpsclient/")
(license license:bsd-3)))
+(define-public python-noiseprotocol
+ (package
+ (name "python-noiseprotocol")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "noiseprotocol" version))
+ (sha256
+ (base32 "0ifnj0mpbqsfqba9n12vf5yzxj4qf2gxql3ry43qyshgnrqsi4mh"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-cryptography))
+ (home-page "https://github.com/plizonczyk/noiseprotocol")
+ (synopsis "Implementation of Noise Protocol Framework")
+ (description
+ "This package provides an implementation of Noise Protocol Framework.")
+ (license license:expat)))
+
(define-public python-websocket-client
(package
(name "python-websocket-client")