aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/potassco.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/potassco.scm')
-rw-r--r--gnu/packages/potassco.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 16cff245e7..e1dbaefa98 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -411,7 +411,11 @@ Python code.")))
(version (package-version clingo-dl))
(arguments
(list
- #:configure-flags #~'("-DPYCLINGODL_ENABLE=pip")
+ #:configure-flags
+ #~(list "-DPYCLINGODL_ENABLE=pip"
+ (string-append "-DCMAKE_MODULE_PATH="
+ #$(this-package-native-input "python-scikit-build")
+ "/lib/cmake/modules"))
#:tests? #f
#:imported-modules `(,@%cmake-build-system-modules
(guix build python-build-system))
@@ -433,6 +437,8 @@ Python code.")))
(inputs (modify-inputs (package-inputs clingo-dl)
(prepend python-wrapper)))
(propagated-inputs (list python-clingo python-cffi))
+ (native-inputs (modify-inputs (package-native-inputs clingo-dl)
+ (prepend python-scikit-build)))
(synopsis "Python bindings for clingo-dl")
(description "This package allows users to add the clingo-dl propagator
as a theory to clingo from Python code. It also supports running clingo-dl