aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/rust-rspec-1-remove-clippy.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/rust-rspec-1-remove-clippy.patch')
-rw-r--r--gnu/packages/patches/rust-rspec-1-remove-clippy.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/rust-rspec-1-remove-clippy.patch b/gnu/packages/patches/rust-rspec-1-remove-clippy.patch
new file mode 100644
index 0000000000..46c994f7ee
--- /dev/null
+++ b/gnu/packages/patches/rust-rspec-1-remove-clippy.patch
@@ -0,0 +1,16 @@
+Remove the dependency on clippy
+
+diff --git a/Cargo.toml b/Cargo.toml
+index 177cb80..7260c34 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -39,9 +39,6 @@ version = "1.5"
+
+ [dependencies.time]
+ version = "0.2"
+-[build-dependencies.clippy]
+-version = "0.0.153"
+-optional = true
+
+ [features]
+ default = []