aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mdadm-gcc-4.9-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/mdadm-gcc-4.9-fix.patch')
-rw-r--r--gnu/packages/patches/mdadm-gcc-4.9-fix.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/patches/mdadm-gcc-4.9-fix.patch b/gnu/packages/patches/mdadm-gcc-4.9-fix.patch
new file mode 100644
index 0000000000..222fd0ea32
--- /dev/null
+++ b/gnu/packages/patches/mdadm-gcc-4.9-fix.patch
@@ -0,0 +1,38 @@
+From 68641cdb646eaa15099c1d6cfff1eaa5dd2ac841 Mon Sep 17 00:00:00 2001
+From: Jes Sorensen <Jes.Sorensen@redhat.com>
+Date: Tue, 24 Feb 2015 16:00:40 -0500
+Subject: [PATCH] write_super_imsm_spares(): C statements are terminated by ;
+
+Signed-off-by: Jes Sorensen <Jes.Sorensen@redhat.com>
+Signed-off-by: NeilBrown <neilb@suse.de>
+---
+ super-intel.c | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/super-intel.c b/super-intel.c
+index 819e0da..7f75b53 100644
+--- a/super-intel.c
++++ b/super-intel.c
+@@ -5115,13 +5115,13 @@ static int write_super_imsm_spares(struct intel_super *super, int doclose)
+ __u32 sum;
+ struct dl *d;
+
+- spare->mpb_size = __cpu_to_le32(sizeof(struct imsm_super)),
+- spare->generation_num = __cpu_to_le32(1UL),
++ spare->mpb_size = __cpu_to_le32(sizeof(struct imsm_super));
++ spare->generation_num = __cpu_to_le32(1UL);
+ spare->attributes = MPB_ATTRIB_CHECKSUM_VERIFY;
+- spare->num_disks = 1,
+- spare->num_raid_devs = 0,
+- spare->cache_size = mpb->cache_size,
+- spare->pwr_cycle_count = __cpu_to_le32(1),
++ spare->num_disks = 1;
++ spare->num_raid_devs = 0;
++ spare->cache_size = mpb->cache_size;
++ spare->pwr_cycle_count = __cpu_to_le32(1);
+
+ snprintf((char *) spare->sig, MAX_SIGNATURE_LENGTH,
+ MPB_SIGNATURE MPB_VERSION_RAID0);
+--
+2.4.3
+