aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch')
-rw-r--r--gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch b/gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch
new file mode 100644
index 0000000000..042f0e025a
--- /dev/null
+++ b/gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch
@@ -0,0 +1,16 @@
+Patch based on changes from
+https://github.com/llvm/llvm-project/commit/c1fde4fa943fd03a3d40bc5d32b9e0045fd29208
+
+diff --git a/lib/sanitizer_common/scripts/gen_dynamic_list.py b/lib/sanitizer_common/scripts/gen_dynamic_list.py
+index 5ea2ca1..d7bc287 100755
+--- a/lib/sanitizer_common/scripts/gen_dynamic_list.py
++++ b/lib/sanitizer_common/scripts/gen_dynamic_list.py
+@@ -100,7 +100,7 @@ def main(argv):
+ print('global:')
+ result.sort()
+ for f in result:
+- print(' ' + f.encode('utf-8') + ';')
++ print(u' %s;' % f)
+ if args.version_list:
+ print('local:')
+ print(' *;')