aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/chromium-disable-third-party-cookies.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/chromium-disable-third-party-cookies.patch')
-rw-r--r--gnu/packages/patches/chromium-disable-third-party-cookies.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/chromium-disable-third-party-cookies.patch b/gnu/packages/patches/chromium-disable-third-party-cookies.patch
new file mode 100644
index 0000000000..0694c35f36
--- /dev/null
+++ b/gnu/packages/patches/chromium-disable-third-party-cookies.patch
@@ -0,0 +1,13 @@
+Disable third party cookies by default.
+
+--- a/components/content_settings/core/browser/cookie_settings.cc
++++ b/components/content_settings/core/browser/cookie_settings.cc
+@@ -101,7 +101,7 @@ void CookieSettings::GetCookieSettings(
+ void CookieSettings::RegisterProfilePrefs(
+ user_prefs::PrefRegistrySyncable* registry) {
+ registry->RegisterBooleanPref(
+- prefs::kBlockThirdPartyCookies, false,
++ prefs::kBlockThirdPartyCookies, true,
+ user_prefs::PrefRegistrySyncable::SYNCABLE_PREF);
+ }
+