aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm213
1 files changed, 122 insertions, 91 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index d59859335a..8b95127163 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -130,9 +130,9 @@
;; Latest version of Guix, which may or may not correspond to a release.
;; Note: the 'update-guix-package.scm' script expects this definition to
;; start precisely like this.
- (let ((version "1.1.0")
- (commit "875c01f82dc5f2c4ca82952ea88b3240fbe8bede")
- (revision 30))
+ (let ((version "1.2.0")
+ (commit "2c11cf1b91b07ed8c00b5525ab6a75e81f5cc289")
+ (revision 2))
(package
(name "guix")
@@ -148,7 +148,7 @@
(commit commit)))
(sha256
(base32
- "0mh1hnrk84h5nzqp6aflh9ab3kxr5672c8bx44minzyd26177yik"))
+ "0w9yrky8qx6zwh97aq6z07mxpjixxg5pp7lzw1r72j3qg3rircj2"))
(file-name (string-append "guix-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
@@ -336,7 +336,13 @@ $(prefix)/etc/init.d\n")))
(let ((bash (assoc-ref inputs "bash")))
(substitute* (string-append out "/bin/guix")
(("^#!.*/bash") (string-append "#! " bash "/bin/bash")))))
- #t))))))
+ #t)))
+
+ ;; The 'guix' executable has 'OUT/libexec/guix/guile' as
+ ;; its shebang; that should remain unchanged, thus remove
+ ;; the 'patch-shebangs' phase, which would otherwise
+ ;; change it to 'GUILE/bin/guile'.
+ (delete 'patch-shebangs))))
(native-inputs `(("pkg-config" ,pkg-config)
;; Guile libraries are needed here for
@@ -566,14 +572,14 @@ out) and returning a package that uses that as its 'source'."
(define-public nix
(package
(name "nix")
- (version "2.3.7")
+ (version "2.3.9")
(source (origin
(method url-fetch)
- (uri (string-append "http://nixos.org/releases/nix/nix-"
+ (uri (string-append "https://nixos.org/releases/nix/nix-"
version "/nix-" version ".tar.xz"))
(sha256
(base32
- "15p50jkss6szinisb7axhxybgfi29sm9grz7mxwair8ljj2553yx"))))
+ "1yi2c1fp33sxv9j0pvxlpxs1dhq3axrwkxdwr867ll90lbdiycvj"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--sysconfdir=/etc" "--enable-gc")
@@ -641,6 +647,25 @@ letting you install them apart in distinct directories and then create
symlinks to the files in a common directory such as /usr/local.")
(license license:gpl3+)))
+(define-public xstow
+ (package
+ (name "xstow")
+ (version "1.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/xstow/xstow-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1vy6lcswpkixh7h5mvsmq2wbcih6lpsmcva3m7v6f5npllciy13g"))))
+ (build-system gnu-build-system)
+ (synopsis "Replacement of GNU Stow written in C++")
+ (description
+ "XStow is a replacement of GNU Stow written in C++. It supports all
+features of Stow with some extensions.")
+ (home-page "http://xstow.sourceforge.net/")
+ (license license:gpl2)))
+
(define-public rpm
(package
(name "rpm")
@@ -990,90 +1015,96 @@ environments.")
(license (list license:gpl3+ license:agpl3+ license:silofl1.1))))
(define-public guix-build-coordinator
- (let ((commit "e701d4d7f24a11d94cf504e7efbcee4e1091b092")
- (revision "1"))
+ (let ((commit "ed3b2e56655ccf4cd9574f00e72b20e9022d9ab0")
+ (revision "8"))
(package
- (name "guix-build-coordinator")
- (version (git-version "0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.cbaines.net/git/guix/build-coordinator")
- (commit commit)))
- (sha256
- (base32
- "16f09sl527b6bgyxs2ybyjfncli60dwzg4v1c58h4hcl2zm8qx70"))
- (file-name (string-append name "-" version "-checkout"))))
- (build-system gnu-build-system)
- (arguments
- `(#:modules (((guix build guile-build-system)
- #:select (target-guile-effective-version))
- ,@%gnu-build-system-modules)
- #:imported-modules ((guix build guile-build-system)
- ,@%gnu-build-system-modules)
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'set-GUILE_AUTO_COMPILE
- (lambda _
- ;; To avoid warnings relating to 'guild'.
- (setenv "GUILE_AUTO_COMPILE" "0")
- #t))
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (guile (assoc-ref inputs "guile"))
- (version (target-guile-effective-version))
- (scm (string-append out "/share/guile/site/" version))
- (go (string-append out "/lib/guile/" version "/site-ccache")))
- (for-each
- (lambda (file)
- (simple-format (current-error-port) "wrapping: ~A\n" file)
- (wrap-program file
- `("PATH" ":" prefix
- (,bin
- ;; Support building without sqitch as an input, as it
- ;; can't be cross-compiled yet
- ,@(or (and=> (assoc-ref inputs "sqitch")
- list)
- '())))
- `("GUILE_LOAD_PATH" ":" prefix
- (,scm ,(getenv "GUILE_LOAD_PATH")))
- `("GUILE_LOAD_COMPILED_PATH" ":" prefix
- (,go ,(getenv "GUILE_LOAD_COMPILED_PATH")))))
- (find-files bin)))
- #t))
- (delete 'strip)))) ; As the .go files aren't compatible
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
-
- ;; Guile libraries are needed here for cross-compilation.
- ("guile-json" ,guile-json-3)
- ("guile-gcrypt" ,guile-gcrypt)
- ("guix" ,guix)
- ("guile-prometheus" ,guile-prometheus)
- ("guile-fibers" ,guile-fibers)
- ("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))))
- (inputs
- `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
- ("guile-fibers" ,guile-fibers)
- ("guile-prometheus" ,guile-prometheus)
- ("guile-gcrypt" ,guile-gcrypt)
- ("guile-json" ,guile-json-3)
- ("guile-lzlib" ,guile-lzlib)
- ("guile-sqlite3" ,guile-sqlite3)
- ("guix" ,guix)
- ("sqlite" ,sqlite)
- ("sqitch" ,sqitch)))
- (home-page "https://git.cbaines.net/guix/build-coordinator/")
- (synopsis "Tool to help build derivations")
- (description
- "The Guix Build Coordinator helps with performing lots of builds across
+ (name "guix-build-coordinator")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.cbaines.net/git/guix/build-coordinator")
+ (commit commit)))
+ (sha256
+ (base32
+ "15c7398km1870w82410jrmcnb4mvkhrsb8qvshr8wa1gjcpb6s6z"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:modules (((guix build guile-build-system)
+ #:select (target-guile-effective-version))
+ ,@%gnu-build-system-modules)
+ #:imported-modules ((guix build guile-build-system)
+ ,@%gnu-build-system-modules)
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-GUILE_AUTO_COMPILE
+ (lambda _
+ ;; To avoid warnings relating to 'guild'.
+ (setenv "GUILE_AUTO_COMPILE" "0")
+ #t))
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (guile (assoc-ref inputs "guile"))
+ (version (target-guile-effective-version))
+ (scm (string-append out "/share/guile/site/" version))
+ (go (string-append out "/lib/guile/" version "/site-ccache")))
+ (for-each
+ (lambda (file)
+ (simple-format (current-error-port) "wrapping: ~A\n" file)
+ (wrap-program file
+ `("PATH" ":" prefix
+ (,bin
+ ;; Support building without sqitch as an input, as it
+ ;; can't be cross-compiled yet
+ ,@(or (and=> (assoc-ref inputs "sqitch")
+ list)
+ '())))
+ `("GUILE_LOAD_PATH" ":" prefix
+ (,scm ,(getenv "GUILE_LOAD_PATH")))
+ `("GUILE_LOAD_COMPILED_PATH" ":" prefix
+ (,go ,(getenv "GUILE_LOAD_COMPILED_PATH")))))
+ (find-files bin)))
+ #t))
+ (delete 'strip)))) ; As the .go files aren't compatible
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gnutls" ,gnutls)
+
+ ;; Guile libraries are needed here for cross-compilation.
+ ("guile-json" ,guile-json-4)
+ ("guile-gcrypt" ,guile-gcrypt)
+ ("guix" ,guix)
+ ("guile-prometheus" ,guile-prometheus)
+ ("guile-fibers" ,guile-fibers)
+ ("guile-lib" ,guile-lib)
+ ("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))))
+ (inputs
+ `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
+ ("sqlite" ,sqlite)
+ ("sqitch" ,sqitch)))
+ (propagated-inputs
+ `(("guile-fibers" ,guile-fibers)
+ ("guile-prometheus" ,guile-prometheus)
+ ("guile-gcrypt" ,guile-gcrypt)
+ ("guile-json" ,guile-json-4)
+ ("guile-lib" ,guile-lib)
+ ("guile-lzlib" ,guile-lzlib)
+ ("guile-zlib" ,guile-zlib)
+ ("guile-sqlite3" ,guile-sqlite3)
+ ("guix" ,guix)
+ ("gnutls" ,gnutls)))
+ (home-page "https://git.cbaines.net/guix/build-coordinator/")
+ (synopsis "Tool to help build derivations")
+ (description
+ "The Guix Build Coordinator helps with performing lots of builds across
potentially many machines, and with doing something with the results and
outputs of those builds.")
- (license license:gpl3+))))
+ (license license:gpl3+))))
(define-public guix-jupyter
(package
@@ -1242,7 +1273,7 @@ for packaging and deployment of cross-compiled Windows applications.")
(define-public libostree
(package
(name "libostree")
- (version "2020.7")
+ (version "2020.8")
(source
(origin
(method url-fetch)
@@ -1250,7 +1281,7 @@ for packaging and deployment of cross-compiled Windows applications.")
"https://github.com/ostreedev/ostree/releases/download/v"
(version-major+minor version) "/libostree-" version ".tar.xz"))
(sha256
- (base32 "0clriq2ypz1fycd6mpjyrhzid44svzpzw0amnank593h69b216ax"))))
+ (base32 "16v73v63h16ika73kgh2cvgm0v27r2d48m932mbj3xm6s295kapx"))))
(build-system gnu-build-system)
(arguments
'(#:phases