aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index bd7b2cc3a7..2c16f24e55 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -644,11 +644,9 @@ code for interfacing Caml with C from an IDL description of the C functions.")
(sha256
(base32
"1jydzw2n84cfiz9y6lk4gih4wbr8jybanmiryfs01svd07g4vpjq"))))
- (build-system ocaml-build-system)
+ (build-system dune-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ (list #:package "extlib"))
(native-inputs
(list ocaml-cppo))
(home-page "https://github.com/ygrek/ocaml-extlib")
@@ -8344,9 +8342,14 @@ library FFTW.")
(properties '((tunable? . #t)))
(build-system dune-build-system)
(arguments
- `(#:tests? #f)) ; No test target.
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'find-openblas
+ (lambda* _
+ (setenv "LACAML_LIBS" "-lopenblas"))))
+ #:tests? #f)) ; No test target.
(native-inputs
- (list openblas lapack ocaml-base ocaml-stdio))
+ (list openblas ocaml-base ocaml-stdio))
(home-page "https://mmottl.github.io/lacaml/")
(synopsis
"OCaml-bindings to BLAS and LAPACK")