aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm40
1 files changed, 38 insertions, 2 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 82987d5f9c..04461fec2d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2020, 2021 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2017-2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017, 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
@@ -959,7 +959,7 @@ systems with no further dependencies.")
(inputs
(list bluez
dbus
- librsvg
+ (librsvg-for-system)
glib
gtk+
iproute
@@ -4615,6 +4615,42 @@ that vnStat won't actually be sniffing any traffic and also ensures light use
of system resources regardless of network traffic rate.")
(license license:gpl2+)))
+(define-public dnstracer
+ (package
+ (name "dnstracer")
+ (version "1.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.mavetju.org/download/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "089bmrjnmsga2n0r4xgw4bwbf41xdqsnmabjxhw8lngg2pns1kb4"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;no test suite
+ #:make-flags #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("\\$\\{PREFIX}/man")
+ "${PREFIX}/share/man")
+ (("^install:.*" all)
+ (string-append
+ all
+ "\tinstall -d ${BINPREFIX}\n"
+ "\tinstall -d ${MANPREFIX}\n")))))
+ (delete 'configure))))
+ (native-inputs (list perl)) ;for pod2man
+ (home-page "http://www.mavetju.org/unix/dnstracer.php")
+ (synopsis "Trace a chain of DNS servers to the source")
+ (description "@command{dnstracer} determines where a given Domain Name
+Server (DNS) gets its information from, and follows the chain of DNS servers
+back to the servers which know the data.")
+ (license license:bsd-2)))
+
(define-public dropwatch
(package
(name "dropwatch")