aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm54
1 files changed, 44 insertions, 10 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 0f35bca9f3..4c266c22aa 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2020, 2021 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2017-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017, 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
@@ -64,6 +64,7 @@
;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2024 Alexey Abramov <levenson@mmer.org>
+;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -99,6 +100,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages adns)
+ #:use-module (gnu packages aidc)
#:use-module (gnu packages algebra)
#:use-module (gnu packages audio)
#:use-module (gnu packages autogen)
@@ -121,6 +123,8 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gawk)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages gd)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
@@ -144,6 +148,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages kerberos)
+ #:use-module (gnu packages man)
#:use-module (gnu packages mpi)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages nettle)
@@ -3083,9 +3088,14 @@ does not use SSH and requires a pre-shared symmetric key.")
(base32
"1lsksqxij5f1llqn86pkygrf5672kvrqn1kvxghi169hqf1c0r73"))
(patches
- (search-patches "quagga-reproducible-build.patch"))))
+ (search-patches "quagga-reproducible-build.patch"))
+ (snippet
+ #~(begin (delete-file "lib/memtypes.h")
+ (delete-file "lib/route_types.h")
+ (delete-file "lib/version.h")
+ (delete-file "vtysh/extract.pl")))))
(build-system gnu-build-system)
- (native-inputs (list pkg-config perl dejagnu))
+ (native-inputs (list gawk gcc-9 pkg-config perl dejagnu))
(inputs (list readline c-ares))
(synopsis "Routing Software Suite")
(description "Quagga is a routing software suite, providing implementations
@@ -4053,14 +4063,14 @@ protocol daemons for BGP, IS-IS, LDP, OSPF, PIM, and RIP.")
(define-public bird
(package
(name "bird")
- (version "2.0.11")
+ (version "2.15.1")
(source (origin
(method url-fetch)
(uri (string-append "ftp://bird.network.cz/pub/bird/bird-"
version ".tar.gz"))
(sha256
(base32
- "1mjm7w5zkbc5q2v4bdn7mcqzcq94s7fiz8a5lz98kl5rcwxvi9v0"))))
+ "0pf7fp78jrblhbcd1zrp07ywjp59m38pm9rf2dn7ar715mi5rs28"))))
(inputs
(list libssh readline))
(native-inputs
@@ -4152,6 +4162,30 @@ libraries and instead utilizing features provided by the Linux kernel to the
maximum extent possible.")
(license license:lgpl2.1+)))
+(define-public iwgtk
+ (package
+ (name "iwgtk")
+ (version "0.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/J-Lentz/iwgtk")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fvxq4ydhzisfn93pcqbspqqi8fwj45v8q104bkm4qfzhf5nvp7w"))))
+ (build-system meson-build-system)
+ (inputs (list gtk qrencode))
+ (native-inputs (list gettext-minimal pkg-config scdoc))
+ (home-page "https://github.com/J-Lentz/iwgtk")
+ (synopsis "Lightweight front-end for iwd")
+ (description "Wireless networking GUI front-end for iwd, with supported
+functionality similar to that of iwctl. Features include viewing and connecting
+to available networks, managing known networks, provisioning new networks via
+WPS or Wi-Fi Easy Connect, and an indicator icon displaying connection status
+and signal strength.")
+ (license license:gpl3+)))
+
(define-public libyang
(package
(name "libyang")
@@ -4539,7 +4573,7 @@ network.")
(define-public ngtcp2
(package
(name "ngtcp2")
- (version "1.4.0")
+ (version "1.5.0")
(source
(origin
(method url-fetch)
@@ -4547,7 +4581,7 @@ network.")
"releases/download/v" version "/"
"ngtcp2-" version ".tar.xz"))
(sha256
- (base32 "0jnay7m4zkg6v2zcidswv9xbyjgsvjbhwf8ykqjcw1jwkwxl7ldm"))))
+ (base32 "0zw5vd1yjfh9j4gl3ixisp495fp9g7qxn1kxkc1dc4v3ps63ch1a"))))
(build-system gnu-build-system)
(arguments
(list
@@ -4585,7 +4619,7 @@ QUIC protocol.")
;; TODO: figure out how tests are run
#:tests? #f
#:install-source? #f
- #:go go-1.20
+ #:go go-1.21
#:phases
#~(modify-phases %standard-phases
(replace 'build
@@ -4813,7 +4847,7 @@ Further information on the usage could be found on the Wikibooks page
(define-public putty
(package
(name "putty")
- (version "0.79")
+ (version "0.81")
(source
(origin
(method url-fetch)
@@ -4822,7 +4856,7 @@ Further information on the usage could be found on the Wikibooks page
(string-append "http://www.putty.be/" version
"/putty-" version ".tar.gz")))
(sha256
- (base32 "1n7h1vprayfgjr21ccsv77g71k8dk10n69y99azqx4xvdxkci322"))))
+ (base32 "1zirfs2zh1jj2i7jcdkyvnq6pliyg8fjipx38pir8d259ylh12yb"))))
(build-system cmake-build-system)
(arguments
`(#:phases