aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm92
1 files changed, 58 insertions, 34 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ceac94a592..90bfe1c891 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015-2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
-;;; Copyright © 2016, 2017, 2019, 2021-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019, 2021-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2018, 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
@@ -55,6 +55,7 @@
;;; Copyright © 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 Parnikkapore <poomklao@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -603,19 +604,27 @@ you create custom user interfaces for your MIDI hardware.")
(define-public qmmp
(package
(name "qmmp")
- (version "2.1.6")
+ (version "2.1.7")
(source
(origin
(method url-fetch)
- (uri (string-append "https://qmmp.ylsoftware.com/files/"
+ (uri (string-append "https://qmmp.ylsoftware.com/files/qmmp/"
(version-major+minor version) "/"
"qmmp-" version ".tar.bz2"))
(sha256
- (base32 "1jpflf17198ascaqmxla6ajb69bnj8zzngk32vdyyw5443kshylj"))))
+ (base32 "0wqy4dh5cci67d822zn2535l0vsvd9c9sqsbscz4j530c6y6g9z6"))))
(build-system qt-build-system)
(arguments
(list #:qtbase qtbase
- #:tests? #f)) ; there are no tests
+ #:tests? #f ; there are no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/plugins/Ui/skinned/skinreader.cpp"
+ (("\"(tar|unzip)\"" _ name)
+ (let ((file (string-append "/bin/" name)))
+ (string-append "\"" (search-input-file inputs file) "\"")))))))))
(inputs
;; Missing optional inputs:
;; libsidplay2 ; input plugin
@@ -645,11 +654,15 @@ you create custom user interfaces for your MIDI hardware.")
qttools
soxr
taglib
+ tar ; for loading skins
+ unzip ; for loading skins
wavpack
wildmidi))
(native-inputs
(list pkg-config))
(home-page "https://qmmp.ylsoftware.com")
+ (properties
+ `((release-monitoring-url . "https://qmmp.ylsoftware.com/downloads.php")))
(synopsis "Qt-based music player")
(description "Music player with support for most common audio formats, and
plugins for various additional features such as visualization, effects and
@@ -5261,6 +5274,8 @@ includes LV2 plugins and a JACK standalone client.")
qtsvg-5
qtx11extras
qtxmlpatterns))
+ (propagated-inputs
+ (list `(,alsa-plugins "pulseaudio"))) ;for libasound_module_conf_pulse.so
(synopsis "Music composition and notation software")
(description
"MuseScore is a music score typesetter. Its main purpose is the creation
@@ -5958,8 +5973,6 @@ console music players.")
(build-system go-build-system)
(native-inputs
(list lua
- go-github-com-mattn-go-isatty
- go-github-com-mattn-go-colorable
go-github-com-aarzilli-golua
go-gitlab-com-ambrevar-damerau
go-gitlab-com-ambrevar-golua-unicode
@@ -6197,47 +6210,56 @@ and reverb.")
(define-public lsp-plugins
(package
(name "lsp-plugins")
- (version "1.2.3")
+ (version "1.2.15")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/sadko4u/lsp-plugins"
+ (uri (string-append "https://github.com/lsp-plugins/lsp-plugins"
"/releases/download/" version
"/lsp-plugins-src-" version ".tar.gz"))
(sha256
- (base32 "0asgwrkyncxz5h7kjkbwm78z8l2jndxvsrgd634m5x9n37gjsgvs"))))
+ (base32 "1bpkbmy8djz304rlsf9zp7bkyc874gnpfihkigqg4fj667x2xfcj"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- (list
- (string-append "CC=" ,(cc-for-target))
- "BUILD_MODULES=\"lv2 ladspa jack\"" "VST_UI=0"
- (string-append "PREFIX=" (assoc-ref %outputs "out"))
- (string-append "ETC_PATH=" (assoc-ref %outputs "out") "/etc"))
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (invoke "make" "config" "TEST=1"
- (string-append "PREFIX=" out)
- (string-append "ETCDIR=" out "/etc")))))
- (replace 'check
- (lambda _
- (invoke ".build/host/lsp-plugin-fw/lsp-plugins-test" "utest"))))))
+ (list
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "make" "config"
+ "STRICT=1"
+ "TEST=1"
+ "FEATURES=clap doc jack ladspa lv2 vst2 xdg"
+ (string-append "PREFIX=" #$output)
+ (string-append "ETCDIR=" #$output "/etc"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke ".build/host/lsp-plugin-fw/lsp-plugins-test" "utest"))))
+ (add-after 'install 'move-large-subdirs
+ (lambda _
+ (define (move-to-output output path)
+ (let ((source (string-append #$output path))
+ (target (string-append output path)))
+ (mkdir-p (dirname target))
+ (rename-file source target)))
+ (move-to-output #$output:doc "/share/doc") ; 29MB
+ (move-to-output #$output:lv2 "/lib/lv2") ; 32MB
+ (move-to-output #$output:bin "/bin") ; Avoid cluttering xdg menu
+ (move-to-output #$output:bin "/share")
+ (move-to-output #$output:bin "/etc"))))))
(inputs
(list cairo
freetype
- hicolor-icon-theme
- jack-1
- ladspa
+ jack-2
libsndfile
libx11
libxrandr
- lv2
mesa))
- (native-inputs
- (list pkg-config php))
+ (native-inputs (list pkg-config php))
+ (outputs '("out" "doc" "lv2" "debug"))
(synopsis "Audio plugin collection")
(description "LSP (Linux Studio Plugins) is a collection of audio
plugins available as LADSPA/LV2 plugins and as standalone JACK
@@ -7275,7 +7297,8 @@ plugin and a standalone JACK application.")
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target
- #:make-flags (list "CC=gcc")
+ #:make-flags (list "CC=gcc"
+ "NOOPT=true")
#:phases
(modify-phases %standard-phases
(delete 'configure) ;no configure target
@@ -7309,6 +7332,7 @@ plugin and a standalone JACK application.")
(description "Wolf Shaper is a waveshaper plugin with a graph editor.
It is provided as an LV2 plugin and as a standalone Jack application.")
(home-page "https://pdesaulniers.github.io/wolf-shaper/")
+ (properties `((tunable? . #t)))
(license license:gpl3)))
(define-public wolf-spectrum