aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 954c12c6f2..ebf9238906 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Dave Love <fx@gnu.org>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
@@ -143,7 +143,7 @@ bind processes, and much more.")
;; Note: 2.x isn't the default yet, see above.
(package
(inherit hwloc-1)
- (version "2.7.1")
+ (version "2.8.0")
(source (origin
(method url-fetch)
(uri (string-append "https://download.open-mpi.org/release/hwloc/v"
@@ -151,7 +151,7 @@ bind processes, and much more.")
"/hwloc-" version ".tar.bz2"))
(sha256
(base32
- "13ajxwshxl1pa8b5gnkmm7hcg97m6xrlgz8vj1hmsb57qcv1skhd"))))
+ "1ha23yqfx9kfxm5fcj9m0fnyf0r2k6p4k88xxqishclcsky752il"))))
;; libnuma is no longer needed.
(inputs (modify-inputs (package-inputs hwloc-1)
@@ -217,17 +217,21 @@ bind processes, and much more.")
(if-supported psm)
(if-supported psm2)
(if-supported ucx)
+ (if-supported valgrind)
(list rdma-core
- valgrind
slurm)))) ;for PMI support (launching via "srun")
(native-inputs
(list pkg-config perl))
(outputs '("out" "debug"))
(arguments
`(#:configure-flags `("--enable-mpi-ext=affinity" ;cr doesn't work
- "--enable-memchecker"
"--with-sge"
- "--with-valgrind"
+
+ ,@(if ,(package? (this-package-input "valgrind"))
+ `("--enable-memchecker"
+ "--with-valgrind")
+ `("--without-valgrind"))
+
"--with-hwloc=external"
"--with-libevent"