aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f91d3e5ba6..479591889f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8095,6 +8095,12 @@ easily be incorporated into existing simulation codes.")
#:parallel-tests? #f ;tests use 'mpiexec -n4'
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ ;; Skip failing tests (SIGFPE and SIGSEGV).
+ (substitute* "ReleaseTests/CMakeLists.txt"
+ (("^.*SpAsgnTest.*$") "")
+ (("^.*IndexingTest.*$") ""))))
(add-before 'check 'mpi-setup
,%openmpi-setup)
(add-before 'check 'test-setup