aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm30
1 files changed, 18 insertions, 12 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7398175837..f91d3e5ba6 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3516,7 +3516,8 @@ September 2004}")
data structures and routines for the scalable (parallel) solution of
scientific applications modeled by partial differential equations.")
(license (license:non-copyleft
- "https://www.mcs.anl.gov/petsc/documentation/copyright.html"))))
+ "https://www.mcs.anl.gov/petsc/documentation/copyright.html"))
+ (properties '((tunable? . #t)))))
(define-public petsc-complex
(package
@@ -7136,16 +7137,21 @@ set.")
(lambda _
(invoke "make" "-C" "docs")))
(replace 'check
- (lambda _
- (setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/hypre/lib"))
- (setenv "PATH" (string-append "." ":" (getenv "PATH")))
- (invoke "make" "check" "CHECKRUN=")
- (for-each (lambda (filename)
- (let ((size (stat:size (stat filename))))
- (when (positive? size)
- (error (format #f "~a size ~d; error indication~%"
- filename size)))))
- (find-files "test" ".*\\.err$"))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "LD_LIBRARY_PATH"
+ (string-append (getcwd) "/hypre/lib"))
+ (setenv "PATH"
+ (string-append "." ":"
+ (getenv "PATH")))
+ (invoke "make" "check" "CHECKRUN=")
+ (for-each (lambda (filename)
+ (let ((size (stat:size (stat filename))))
+ (when (positive? size)
+ (error (format #f
+ "~a size ~d; error indication~%"
+ filename size)))))
+ (find-files "test" ".*\\.err$")))))
(add-after 'install 'install-docs
(lambda* (#:key outputs #:allow-other-keys)
;; Custom install because docs/Makefile doesn't honor ${docdir}.
@@ -8070,7 +8076,7 @@ easily be incorporated into existing simulation codes.")
".tgz"))
(sha256
(base32
- "1a9wbgdqyy1whhfc0yl0yqkax3amnqa6iihhq48d063gc0jwfd9a"))
+ "0gzxgd2ybnh49h57rh47vrqnsyk11jn206j5kf9y7p5vksc79ffz"))
(patches (search-patches "combinatorial-blas-awpm.patch"
"combinatorial-blas-io-fix.patch"))))
(build-system cmake-build-system)