aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm70
1 files changed, 58 insertions, 12 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index e0fbd0a5ff..b15d891609 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2016, 2017 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016, 2017, 2018 Nikita <nikita@n0.is>
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2016–2023 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016–2024 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
@@ -51,6 +51,7 @@
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2022 ( <paren@disroot.org>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023 Arjan Adriaanse <arjan@adriaan.se>
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
@@ -81,6 +82,7 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages c)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -455,6 +457,48 @@ software. GNU Mailutils provides the following commands:
Maildir, MH, MMDF or mbox folders.")
(license license:gpl2))))
+(define-public nmail
+ (package
+ (name "nmail")
+ (version "4.54")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/d99kris/nmail/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bk2kq0pk1r4w5xv94yh37vrwxs8lczjg11gfraxh9cxyjigwsrp"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ctest" "--output-on-failure")))))))
+ (inputs
+ (list curl
+ cyrus-sasl
+ expat
+ file
+ libetpan
+ ncurses
+ openssl
+ sqlite
+ (list util-linux "lib")
+ xapian
+ zlib))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/d99kris/nmail")
+ (synopsis "Terminal-based email client")
+ (description
+ "@command{nmail} is an easily configurable terminal-based email client
+with a @code{ncurses} user interface similar to @code{alpine} and
+@code{pine}.")
+ (license license:expat)))
+
(define-public go-gitlab.com-shackra-goimapnotify
(package
(name "go-gitlab.com-shackra-goimapnotify")
@@ -767,7 +811,7 @@ It adds a large amount of new and improved features to mutt.")
(define-public gmime
(package
(name "gmime")
- (version "3.2.7")
+ (version "3.2.14")
(source
(origin
(method git-fetch)
@@ -776,7 +820,7 @@ It adds a large amount of new and improved features to mutt.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0yiylbw9iy49hgj29czinv246hh5c18qv6qkvbdrmq9z5m00sp01"))))
+ (base32 "0kvhyd1rn6wi9wrqi2a4f26yp0l6shsg9sd45hckzf04p9687hb7"))))
(build-system gnu-build-system)
(arguments
(list #:configure-flags
@@ -799,7 +843,7 @@ It adds a large amount of new and improved features to mutt.")
(or prog (error "not found: "
base))))))))))))
(native-inputs
- (list autoconf
+ (list autoconf-2.71
automake
pkg-config
gnupg ; for tests only
@@ -1216,14 +1260,14 @@ security functionality including PGP, S/MIME, SSH, and SSL.")
(define-public mu
(package
(name "mu")
- (version "1.12.2")
+ (version "1.12.4")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/djcb/mu/releases/download/v"
version "/mu-" version ".tar.xz"))
(sha256
- (base32 "065nqrsz5bpvhniaacfq67fh78m5pm96svingdviw2hj1y21s6kv"))))
+ (base32 "1ja4b9r9712zjvz8223r5vh2kmmyhkrmb7cbhxdn9hbpa5n16hdx"))))
(build-system meson-build-system)
(native-inputs
(list pkg-config
@@ -1423,11 +1467,12 @@ invoking @command{notifymuch} from the post-new hook.")
emacs-no-x ; -minimal lacks libxml, needed for some tests
which
dtach
+ git-minimal/pinned
gnupg
man-db
perl))
(inputs
- (list glib gmime talloc xapian zlib))
+ (list glib gmime sfsexp talloc xapian zlib))
(home-page "https://notmuchmail.org/")
(synopsis "Thread-based email index, search, and tagging")
(description
@@ -1853,14 +1898,14 @@ addons which can add many functionalities to the base client.")
(define-public msmtp
(package
(name "msmtp")
- (version "1.8.25")
+ (version "1.8.26")
(source
(origin
(method url-fetch)
(uri (string-append "https://marlam.de/msmtp/releases"
"/msmtp-" version ".tar.xz"))
(sha256
- (base32 "0f6pa8kdlfingw6yf61dshnxgygx5v6ykcmnn3h6zllpnfxivzid"))))
+ (base32 "1n363w94s2jjkijnqg5mb4m7wk0dy20s9bk0gqk8kwff8j1liz3c"))))
(build-system gnu-build-system)
(inputs
(list libsecret gnutls zlib gsasl))
@@ -4114,7 +4159,7 @@ It is a replacement for the @command{urlview} program.")
(define-public mumi
(package
(name "mumi")
- (version "0.0.8")
+ (version "0.1.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4123,7 +4168,7 @@ It is a replacement for the @command{urlview} program.")
(file-name (git-file-name name version))
(sha256
(base32
- "1z556pxsz0zx95gd5b4hwkmwcvf3jyz7njkb3zwbhrwnpgygnbyl"))))
+ "1989k5gjb6dgg2fd7bdi0a99dbwkj6bkgyffalvwsfdfm5f2hf5s"))))
(build-system gnu-build-system)
(arguments
(list
@@ -4168,7 +4213,8 @@ It is a replacement for the @command{urlview} program.")
guile-webutils
guile-xapian
guile-3.0
- mailutils))
+ mailutils
+ xdg-utils))
(native-inputs
(list autoconf automake pkg-config sassc
(origin