aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/magic-wormhole.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/magic-wormhole.scm')
-rw-r--r--gnu/packages/magic-wormhole.scm160
1 files changed, 79 insertions, 81 deletions
diff --git a/gnu/packages/magic-wormhole.scm b/gnu/packages/magic-wormhole.scm
index 86a8013aa1..dbb943c5c6 100644
--- a/gnu/packages/magic-wormhole.scm
+++ b/gnu/packages/magic-wormhole.scm
@@ -1,5 +1,8 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2024 normally_js <normally_js@posteo.net>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2024 TakeV <takev@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17,12 +20,14 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages magic-wormhole)
- #:use-module (guix packages)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system pyproject)
+ #:use-module ((guix build-system python) #:select (pypi-uri))
#:use-module (guix download)
- #:use-module (guix licenses)
- #:use-module (guix build-system python)
+ #:use-module (guix gexp)
+ #:use-module (guix packages)
#:use-module (gnu packages check)
- #:use-module (gnu packages python-check)
+ #:use-module (gnu packages python-compression)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz))
@@ -32,24 +37,15 @@
(name "magic-wormhole-mailbox-server")
(version "0.4.1")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "magic-wormhole-mailbox-server" version))
- (sha256
- (base32
- "1yw8i8jv5iv1kkz1aqimskw7fpichjn6ww0fq0czbalwj290bw8s"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-tests
- (lambda _
- ;; This test requires network access.
- (substitute* "src/wormhole_mailbox_server/test/test_web.py"
- (("test_log_http") "disabled_test_log_http"))
- #t)))))
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "magic-wormhole-mailbox-server" version))
+ (sha256
+ (base32
+ "1yw8i8jv5iv1kkz1aqimskw7fpichjn6ww0fq0czbalwj290bw8s"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-mock))
+ (list python-mock python-pytest))
(propagated-inputs
(list python-attrs
python-autobahn
@@ -58,79 +54,77 @@
python-six
python-treq
python-twisted))
- (home-page "https://github.com/warner/magic-wormhole-mailbox-server")
+ (home-page "https://github.com/magic-wormhole/magic-wormhole-mailbox-server")
(synopsis "Magic-Wormhole central mailbox server")
- (description "This package provides the main server that Magic-Wormhole
-clients connect to. The server performs store-and-forward delivery for small
+ (description
+ "This package provides the main server that Magic-Wormhole clients
+connect to. The server performs store-and-forward delivery for small
key-exchange and control messages. Bulk data is sent over a direct TCP
connection, or through a transit-relay.")
- (license expat)))
+ (license license:expat)))
(define-public magic-wormhole-transit-relay
(package
(name "magic-wormhole-transit-relay")
(version "0.2.1")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "magic-wormhole-transit-relay" version))
- (sha256
- (base32
- "0ppsx2s1ysikns1h053x67z2zmficbn3y3kf52bzzslhd2s02j6b"))))
- (build-system python-build-system)
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "magic-wormhole-transit-relay" version))
+ (sha256
+ (base32
+ "0ppsx2s1ysikns1h053x67z2zmficbn3y3kf52bzzslhd2s02j6b"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-docs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (docs (string-append out "/share/doc/magic-wormhole-transit-relay")))
- (for-each (lambda (file)
- (install-file file docs))
- (find-files "docs/"))
- #t))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-docs
+ (lambda _
+ (let* ((out #$output)
+ (docs (string-append out "/share/doc/magic-wormhole-transit-relay")))
+ (for-each (lambda (file)
+ (install-file file docs))
+ (find-files "docs/"))))))))
(native-inputs
- (list python-mock python-pyflakes python-tox))
+ (list python-mock python-pytest))
(propagated-inputs
(list python-twisted))
- (home-page
- "https://github.com/warner/magic-wormhole-transit-relay")
+ (home-page "https://github.com/magic-wormhole/magic-wormhole-transit-relay")
(synopsis "Magic-Wormhole relay server")
- (description "This package provides the Magic-Wormhole Transit Relay
-server, which helps clients establish bulk-data transit connections even when
-both are behind NAT boxes. Each side makes a TCP connection to this server and
+ (description
+ "This package provides the Magic-Wormhole Transit Relay server, which
+helps clients establish bulk-data transit connections even when both are
+behind NAT boxes. Each side makes a TCP connection to this server and
presents a handshake. Two connections with identical handshakes are glued
together, allowing them to pretend they have a direct connection.")
- (license expat)))
+ (license license:expat)))
(define-public magic-wormhole
(package
(name "magic-wormhole")
- (version "0.12.0")
+ (version "0.14.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "magic-wormhole" version))
- (sha256
- (base32
- "0q41j99718y7m95zg1vaybnsp31lp6lhyqkbv4yqz5ys6jixh3qv"))))
- (build-system python-build-system)
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "magic-wormhole" version))
+ (sha256
+ (base32
+ "105hsv7ck83bs29929zpb29aygr69q00mxpgq9xw7xxzi2gj6v80"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- ;; XXX I can't figure out how to build the docs properly.
- ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34515#101
- (add-after 'install 'install-docs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (man (string-append out "/share/man/man1")))
- (install-file "docs/wormhole.1" man))
- #t)))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX I can't figure out how to build the docs properly.
+ ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34515#101
+ (add-after 'install 'install-docs
+ (lambda _
+ (install-file "docs/wormhole.1"
+ (string-append #$output "/share/man/man1")))))))
(native-inputs
(list python-mock
- ;; XXX These are required for the test suite but end up being referenced
- ;; by the built package.
- ;; https://bugs.gnu.org/25235
+ python-pytest
magic-wormhole-mailbox-server
magic-wormhole-transit-relay))
(propagated-inputs
@@ -138,22 +132,26 @@ together, allowing them to pretend they have a direct connection.")
python-click
python-hkdf
python-humanize
+ python-iterable-io
+ python-noiseprotocol
python-pynacl
python-spake2
python-tqdm
python-twisted
- python-txtorcon))
- (home-page "https://github.com/warner/magic-wormhole")
+ python-txtorcon
+ python-zipstream-ng))
+ (home-page "https://github.com/magic-wormhole/magic-wormhole")
(synopsis "Securely transfer data between computers")
- (description "Magic-Wormhole is a library and a command-line tool named
-wormhole, which makes it possible to securely transfer arbitrary-sized files and
+ (description
+ "Magic-Wormhole is a library and a command-line tool named wormhole,
+which makes it possible to securely transfer arbitrary-sized files and
directories (or short pieces of text) from one computer to another. The two
-endpoints are identified by using identical \"wormhole codes\": in general, the
-sending machine generates and displays the code, which must then be typed into
-the receiving machine.
+endpoints are identified by using identical \"wormhole codes\": in general,
+the sending machine generates and displays the code, which must then be typed
+into the receiving machine.
The codes are short and human-pronounceable, using a phonetically-distinct
-wordlist. The receiving side offers tab-completion on the codewords, so usually
-only a few characters must be typed. Wormhole codes are single-use and do not
-need to be memorized.")
- (license expat)))
+wordlist. The receiving side offers tab-completion on the codewords, so
+usually only a few characters must be typed. Wormhole codes are single-use
+and do not need to be memorized.")
+ (license license:expat)))