aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm69
1 files changed, 69 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 92cc468871..2e20872555 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2024 David Pflug <david@pflug.io>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -73,6 +74,7 @@
#:use-module (gnu packages cran)
#:use-module (gnu packages databases)
#:use-module (gnu packages dejagnu)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
@@ -660,6 +662,53 @@ networks) based on simulation of (stochastic) flow in graphs.")
algorithm.")
(license license:gpl3)))
+(define-public openmm
+ (package
+ (name "openmm")
+ (version "8.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openmm/openmm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "064vv6zaci30pj38z5lwfqscxssm67jqxkz30hcya9vm4ng831d5"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ '(list "-DOPENMM_BUILD_SHARED_LIB=TRUE"
+ "-DOPENMM_BUILD_C_AND_FORTRAN_WRAPPERS=TRUE"
+ "-DOPENMM_BUILD_PYTHON_WRAPPERS=TRUE"
+ "-DOPENMM_BUILD_CUDA_LIB=FALSE")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-python-build-system
+ (lambda _
+ (substitute* "wrappers/python/CMakeLists.txt"
+ (("install --root=\\\\\\$ENV\\{DESTDIR\\}/")
+ (string-append "install --prefix=" #$output
+ " --root=/ --single-version-externally-managed")))))
+ (add-after 'install 'install-python
+ (lambda _
+ (invoke "make" "PythonInstall"))))))
+ (inputs
+ (list python-wrapper))
+ (propagated-inputs
+ (list python-numpy))
+ (native-inputs
+ (list doxygen gfortran opencl-headers python-cython swig))
+ (home-page "https://github.com/openmm/openmm/")
+ (synopsis "Toolkit for molecular simulation")
+ (description
+ "OpenMM is a toolkit for molecular simulation. It can be used either as
+a stand-alone application for running simulations, or as a library you call
+from your own code.")
+ ;; See https://github.com/openmm/openmm/issues/4278#issuecomment-1772982471
+ (license license:expat)))
+
(define-public randomjungle
(package
(name "randomjungle")
@@ -5317,3 +5366,23 @@ Brian 2 simulator.")
"OneAPI Deep Neural Network Library (oneDNN) is a cross-platform
performance library of basic building blocks for deep learning applications.")
(license license:asl2.0)))
+
+(define-public python-gguf
+ (package
+ (name "python-gguf")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gguf" version))
+ (sha256
+ (base32 "0rbyc2h3kpqnrvbyjvv8a69l577jv55a31l12jnw21m1lamjxqmj"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #false))
+ (inputs (list poetry python-pytest))
+ (propagated-inputs (list python-numpy))
+ (home-page "https://ggml.ai")
+ (synopsis "Read and write ML models in GGUF for GGML")
+ (description "A Python library for reading and writing GGUF & GGML format ML models.")
+ (license license:expat)))