aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm36
1 files changed, 31 insertions, 5 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 6e94e21f3e..5c18a2e9d5 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 David Pflug <david@pflug.io>
;;; Copyright © 2024 Timothee Mathieu <timothee.mathieu@inria.fr>
+;;; Copyright © 2024 Spencer King <spencer.king@geneoscopy.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -523,8 +524,8 @@ Performance is achieved by using the LLVM JIT compiler.")
(deprecated-package "guile-aiscm-next" guile-aiscm))
(define-public llama-cpp
- (let ((commit "f31b5397143009d682db90fd2a6cde83f1ef00eb")
- (revision "0"))
+ (let ((commit "03bf161eb6dea6400ee49c6dc6b69bdcfa9fd3fc")
+ (revision "1"))
(package
(name "llama-cpp")
(version (git-version "0.0.0" revision commit))
@@ -533,10 +534,10 @@ Performance is achieved by using the LLVM JIT compiler.")
(method git-fetch)
(uri (git-reference
(url "https://github.com/ggerganov/llama.cpp")
- (commit (string-append "master-" (string-take commit 7)))))
+ (commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0ys6n53n032zq1ll9f3vgxk8sw0qq7x3fi7awsyy13adzp3hn08p"))))
+ (base32 "1ag1jash84hasz10h0piw72a8ginm8kzvhihbzzljz96gq2kjm88"))))
(build-system cmake-build-system)
(arguments
(list
@@ -563,8 +564,10 @@ Performance is achieved by using the LLVM JIT compiler.")
(get-string-all input))))))
(chmod (string-append bin script) #o555)))
(mkdir-p bin)
- (make-script "convert-pth-to-ggml")
+ (make-script "convert-hf-to-gguf")
+ (make-script "convert-llama-ggml-to-gguf")
(make-script "convert-lora-to-ggml")
+ (make-script "convert-persimmon-to-gguf")
(make-script "convert"))))
(add-after 'install-python-scripts 'wrap-python-scripts
(assoc-ref python:%standard-phases 'wrap))
@@ -1782,6 +1785,29 @@ scikit-learn inclusion criteria, for instance due to their novelty or lower
citation number.")
(license license:bsd-3))))
+(define-public python-mord
+ (package
+ (name "python-mord")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mord" version))
+ (sha256
+ (base32 "1cvv9b9w69v0inq0zgcw0vmkiq3zn9q9r6clkynpzjik9rrh405n"))))
+ (build-system pyproject-build-system)
+ ;; v0.7 does not provide any test cases
+ ;; v0.6 relies on deprecated scikit-learn functionality
+ (arguments `(#:tests? #f))
+ (inputs (list python-numpy python-scipy python-scikit-learn))
+ (home-page "https://pypi.org/project/mord/")
+ (synopsis "Ordinal regression models for scikit-learn")
+ (description
+ "This package provides a collection of ordinal regression models for
+machine learning in Python. They are intended to be used with scikit-learn
+and are compatible with its API.")
+ (license license:bsd-3)))
+
(define-public python-thinc
(package
(name "python-thinc")