aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 8d5d3522ec..6b9ab051b4 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -158,7 +158,7 @@ itself as well as other components maintained by the LXQt project.")
(define-public libqtxdg
(package
(name "libqtxdg")
- (version "3.3.1")
+ (version "3.4.0")
(source
(origin
(method url-fetch)
@@ -166,7 +166,7 @@ itself as well as other components maintained by the LXQt project.")
"https://github.com/lxqt/libqtxdg/releases/download/"
version "/libqtxdg-" version ".tar.xz"))
(sha256
- (base32 "1mnnq8vbf5xjlrzajzfkay0yzzxri0zz0xi8x8rmxpw38xmglq8h"))))
+ (base32 "0vmn59653dmy79mnbnibhdq9jmh11091zkfx0y0qh58rj2xvpdbv"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
@@ -181,10 +181,12 @@ itself as well as other components maintained by the LXQt project.")
#t)))))
(propagated-inputs
;; required by Qt5XdgIconLoader.pc
- `(("qtbase" ,qtbase)
+ `(("glib" ,glib)
+ ("qtbase" ,qtbase)
("qtsvg" ,qtsvg)))
(native-inputs
- `(("lxqt-build-tools" ,lxqt-build-tools)))
+ `(("lxqt-build-tools" ,lxqt-build-tools)
+ ("pkg-config" ,pkg-config)))
(home-page "https://github.com/lxqt/libqtxdg")
(synopsis "Qt implementation of freedesktop.org xdg specifications")
(description "Libqtxdg implements the freedesktop.org xdg specifications
@@ -415,14 +417,15 @@ configuration of both LXQt and the underlying operating system.")
(define-public lxqt-globalkeys
(package
(name "lxqt-globalkeys")
- (version "0.14.1")
+ (version "0.14.3")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
- version "/" name "-" version ".tar.xz"))
+ (uri (string-append "https://github.com/lxqt/lxqt-globalkeys/"
+ "releases/download/" version "/"
+ "lxqt-globalkeys-" version ".tar.xz"))
(sha256
- (base32 "0m6svwy20bfy9d21g5l0qzjndph3rd8zqagmqgdjzjhh3lxwrsrk"))))
+ (base32 "0mgl05qxvq4pdqvcw34i2cbyy87x605wy3np62mrbbb1kdfjrfg6"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)