aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f24e92b908..d0fdcc995b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -480,6 +480,21 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
+(define-public linux-libre-6.1-version "6.1.2")
+(define-public linux-libre-6.1-gnu-revision "gnu")
+(define deblob-scripts-6.1
+ (linux-libre-deblob-scripts
+ linux-libre-6.1-version
+ linux-libre-6.1-gnu-revision
+ (base32 "0p1cg5khpp8xkfaqy0cnp1m273z3xiz0m97rkrkggz9gr2klrjym")
+ (base32 "0va28vs359r0rfmzh8pw58055kgd8sb62gi78vrg9p8wmj4s87v6")))
+(define-public linux-libre-6.1-pristine-source
+ (let ((version linux-libre-6.1-version)
+ (hash (base32 "1bni72q0jjg39vqckcif57kh7d1x4k4jir5a11pz9clryp2g6hgf")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-6.1)))
+
(define-public linux-libre-6.0-version "6.0.16")
(define-public linux-libre-6.0-gnu-revision "gnu")
(define deblob-scripts-6.0
@@ -616,6 +631,12 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-6.1-source
+ (source-with-patches linux-libre-6.1-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch
+ (search-patch "linux-libre-infodocs-target.patch"))))
+
(define-public linux-libre-6.0-source
(source-with-patches linux-libre-6.0-pristine-source
(list %boot-logo-patch
@@ -731,6 +752,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-6.1
+ (make-linux-libre-headers* linux-libre-6.1-version
+ linux-libre-6.1-gnu-revision
+ linux-libre-6.1-source))
+
(define-public linux-libre-headers-6.0
(make-linux-libre-headers* linux-libre-6.0-version
linux-libre-6.0-gnu-revision
@@ -1071,6 +1097,14 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
+(define-public linux-libre-6.1
+ (make-linux-libre* linux-libre-6.1-version
+ linux-libre-6.1-gnu-revision
+ linux-libre-6.1-source
+ '("x86_64-linux" "i686-linux" "armhf-linux"
+ "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-6.0
(make-linux-libre* linux-libre-6.0-version
linux-libre-6.0-gnu-revision