aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f33c98d591..1046424c19 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6686,20 +6686,21 @@ The collection contains a set of bandwidth and latency benchmark such as:
"0i00if7xknpm0dhkrm60rxzyyvq0vdibq7dvsd2ncm9pg098qvwj"))))
(build-system gnu-build-system)
(arguments
- `(;; Disable support for various hardware entropy sources as they need
- ;; dependencies that are not yet in Guix, and would significantly
- ;; increase closure size.
- #:configure-flags '("--without-nistbeacon"
- "--without-pkcs11"
- "--without-rtlsdr")
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'disable-failing-test
- (lambda _
- (substitute* "tests/Makefile"
- ;; This test requires a hwrng, rdrand, or tpm device.
- ;; Worse, it appears to fail if that isn't sufficiently random.
- (("\\brngtestjitter\\.sh\\b") " ")))))))
+ (list
+ ;; Disable support for various hardware entropy sources as they need
+ ;; dependencies that are not yet in Guix, and would significantly
+ ;; increase closure size.
+ #:configure-flags #~(list "--without-nistbeacon"
+ "--without-pkcs11"
+ "--without-rtlsdr")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'disable-failing-test
+ (lambda _
+ (substitute* "tests/Makefile"
+ ;; This test requires a hwrng, rdrand, or tpm device.
+ ;; Worse, it appears to fail if that isn't sufficiently random.
+ (("\\brngtestjitter\\.sh\\b") " ")))))))
(native-inputs
(list autoconf automake pkg-config))
(inputs