aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm68
1 files changed, 50 insertions, 18 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ae73b9eab0..63b2ef4602 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -63,6 +63,7 @@
;;; Copyright © 2021, 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Rene Saavedra <nanuui@protonmail.com>
+;;; Copyright © 2022 muradm <mail@muradm.net>
;;;
;;; This file is part of GNU Guix.
@@ -352,6 +353,22 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
+(define-public linux-libre-5.19-version "5.19.5")
+(define-public linux-libre-5.19-gnu-revision "gnu")
+(define deblob-scripts-5.19
+ (linux-libre-deblob-scripts
+ linux-libre-5.19-version
+ linux-libre-5.19-gnu-revision
+ (base32 "0a4pln89nbxiniykm14kyqmnn79gfgj22dr3h94w917xhidq7gp1")
+ (base32 "1ph67fvg5qvlkh4cynrrmvkngkb0sw6k90b1mwy9466s24khn05i")))
+(define-public linux-libre-5.19-pristine-source
+ (let ((version linux-libre-5.19-version)
+ (hash (base32 "1g9p4m9w9y0y1gk6vzqvsxzwqspbm10mmhd8n1mhal1yz721qgwc")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-5.19)))
+
+
(define-public linux-libre-5.18-version "5.18.19")
(define-public linux-libre-5.18-gnu-revision "gnu")
(define deblob-scripts-5.18
@@ -364,7 +381,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(let ((version linux-libre-5.18-version)
(hash (base32 "1mc8zhiw0v7fka64mydpdrxkrvy0jyqggq5lghw3pyqj2wjrpw6z")))
(make-linux-libre-source version
-
(%upstream-linux-source version hash)
deblob-scripts-5.18)))
@@ -386,7 +402,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-5.15)))
-(define-public linux-libre-5.10-version "5.10.138")
+(define-public linux-libre-5.10-version "5.10.139")
(define-public linux-libre-5.10-gnu-revision "gnu1")
(define deblob-scripts-5.10
(linux-libre-deblob-scripts
@@ -396,7 +412,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "1981axxswghza3iadp94q54y8w30h9w9vyq4cbjiiv9alvbv0pb8")))
(define-public linux-libre-5.10-pristine-source
(let ((version linux-libre-5.10-version)
- (hash (base32 "1a2vmcqzi71w88j79lxsrgyycq1l1gxp0cvh5ya4afhfisxh7819")))
+ (hash (base32 "1wdyk1w8lr5l4d038bd44rdndxjvfcva2n51h2i38jd4fp12l00w")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.10)))
@@ -489,6 +505,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-5.19-source
+ (source-with-patches linux-libre-5.19-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-5.18-source
(source-with-patches linux-libre-5.18-pristine-source
(list %boot-logo-patch
@@ -603,6 +624,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-5.19
+ (make-linux-libre-headers* linux-libre-5.19-version
+ linux-libre-5.19-gnu-revision
+ linux-libre-5.19-source))
+
(define-public linux-libre-headers-5.18
(make-linux-libre-headers* linux-libre-5.18-version
linux-libre-5.18-gnu-revision
@@ -924,6 +950,13 @@ It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
+(define-public linux-libre-5.19
+ (make-linux-libre* linux-libre-5.19-version
+ linux-libre-5.19-gnu-revision
+ linux-libre-5.19-source
+ '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-5.18
(make-linux-libre* linux-libre-5.18-version
linux-libre-5.18-gnu-revision
@@ -8047,23 +8080,26 @@ emulates the behaviour of Gunnar Monell's older fbgrab utility.")
(define-public libcgroup
(package
(name "libcgroup")
- (version "0.41")
+ (version "2.0.2")
+ (home-page "https://github.com/libcgroup/libcgroup")
(source
(origin
(method url-fetch)
- (uri (string-append
- "mirror://sourceforge/libcg/" name "/"
- version "/" name "-" version ".tar.bz2"))
+ (uri (string-append home-page "/releases/download/v"
+ version "/" name "-" version ".tar.gz"))
(sha256
- (base32 "0lgvyq37gq84sk30sg18admxaj0j0p5dq3bl6g74a1ppgvf8pqz4"))))
+ (base32 "1y0c9ncsawamj77raiw6qkbm5cdsyvhjb2mvgma1kxmgw0r3pxlf"))))
(build-system gnu-build-system)
(arguments
+ ;; Tests are virtualized with lxc, it is not very feasible
+ ;; to make them executable under guix build. Also, note that
+ ;; origin is using source tarball release which is prepared
+ ;; after testing.
`(#:tests? #f))
(native-inputs
(list bison flex))
(inputs
(list linux-pam))
- (home-page "https://sourceforge.net/projects/libcg/")
(synopsis "Control groups management tools")
(description "Control groups is Linux kernel method for process resource
restriction, permission handling and more. This package provides userspace
@@ -8642,7 +8678,7 @@ of Linux application development.")
(package
(inherit pipewire)
(name "pipewire")
- (version "0.3.43")
+ (version "0.3.56")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -8651,17 +8687,13 @@ of Linux application development.")
(file-name (git-file-name name version))
(sha256
(base32
- "0gp2h0sidapcqmnifl0iipdmbzb18bdh8zdi7pfywr9gsksh0cxy"))))
+ "066g4ri2k8pdflclvr2919f6x98gmqrqyj1xyiingw2nn2pwgcf1"))))
(arguments
'(#:configure-flags
(list (string-append "-Dudevrulesdir=" (assoc-ref %outputs "out")
"/lib/udev/rules.d")
"-Dsystemd=disabled"
- "-Dsession-managers=[]")
- #:phases
- (modify-phases %standard-phases
- ;; Skip shrink-runpath, otherwise validate-runpath fails.
- (delete 'shrink-runpath))))
+ "-Dsession-managers=[]")))
(inputs (modify-inputs (package-inputs pipewire)
(prepend avahi
bluez
@@ -8674,7 +8706,7 @@ of Linux application development.")
(define-public wireplumber
(package
(name "wireplumber")
- (version "0.4.6")
+ (version "0.4.11")
(source
(origin
(method git-fetch)
@@ -8684,7 +8716,7 @@ of Linux application development.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0g7xkgkjlxrhs49hqkwrjk2hb478gq55wwydafvvbsv78vsa7qfb"))))
+ (base32 "09pg5cki1xn9bwn3bcjdc54z7b4iqkk1dhn560qyjcglq8xg7nnw"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dsystemd=disabled"