aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 60a6d7df73..18606f96a1 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -94,14 +94,14 @@ their dependencies automatically upon calculation.")
(define-public orcus
(package
(name "orcus")
- (version "0.7.1")
+ (version "0.9.2")
(source
(origin
(method url-fetch)
(uri (string-append "http://kohei.us/files/" name "/src/lib"
name "-" version ".tar.xz"))
(sha256 (base32
- "0hva4qalg3dk6n1118ncr5fy8cqnj2f7fwldw7aa04124rj6p104"))))
+ "170racjz7s7yxza722hxsqc12788w57qnp6x6j2692pzp3qzjjfx"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -709,7 +709,7 @@ and to return information on pronunciations, meanings and synonyms.")
(define-public libreoffice
(package
(name "libreoffice")
- (version "5.0.5.2")
+ (version "5.1.4.2")
(source
(origin
(method url-fetch)
@@ -718,7 +718,7 @@ and to return information on pronunciations, meanings and synonyms.")
"http://download.documentfoundation.org/libreoffice/src/"
(version-prefix version 3) "/libreoffice-" version ".tar.xz"))
(sha256 (base32
- "120vcxpxzs0za76fyfry281ysv6d1ianb37d1yq8py8chkdjkrqy"))))
+ "11c30y9gvsy5h3nh9pnciq57gi99plrmr6qp8hhdk2l5xmwlmrfa"))))
(build-system gnu-build-system)
(native-inputs
`(;; autoreconf is run by the LibreOffice build system, since after
@@ -730,7 +730,7 @@ and to return information on pronunciations, meanings and synonyms.")
("cppunit" ,cppunit)
("flex" ,flex)
("pkg-config" ,pkg-config)
- ("python" ,python)
+ ("python" ,python-wrapper)
("which" ,which)))
(inputs
`(("bluez" ,bluez)
@@ -851,6 +851,8 @@ and to return information on pronunciations, meanings and synonyms.")
"--disable-coinmp"
"--disable-firebird-sdbc" ; embedded firebird
"--disable-gltf"
+ "--without-doxygen"
+ "--disable-gtk3"
"--disable-liblangtag")))
(home-page "https://www.libreoffice.org/")
(synopsis "Office suite")