aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 42722a79d0..468e2adc3b 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -315,9 +315,8 @@ Notable features include:
;; 'NeedProgs' core utilities are specially checked for
;; availability. It's easier to wrap them in PATH than patching
;; their references.
- ;; TODO: package edid-decode and add "bin/edid-decode" below:
(define need-progs (list "sbin/dmidecode" "sbin/smartctl"
- "bin/lspci" "bin/lsusb"))
+ "bin/lspci" "bin/lsusb" "bin/edid-decode"))
(wrap-script hw-probe
(list "PERL5LIB" 'prefix (list (getenv "PERL5LIB")))
(list "PATH" 'prefix
@@ -626,7 +625,7 @@ through the Display Data Channel Command Interface (@dfn{DDC/CI}) protocol.")
(license (list license:gpl2+))))
(define-public edid-decode
- (let ((commit "74b64180d67bb009d8d9ea1b6f18ad41aaa16396") ; 2020-04-22
+ (let ((commit "3d635499e4aca3319f0796ba787213c981c5a770") ; 2024-04-02
(revision "1"))
(package
(name "edid-decode")
@@ -639,7 +638,7 @@ through the Display Data Channel Command Interface (@dfn{DDC/CI}) protocol.")
(url "git://linuxtv.org/edid-decode.git")
(commit commit)))
(sha256
- (base32 "0nirp5bza08zj5d8bjgcm0p869hdg3qg3mwa7999pjdrzmn7s2ah"))))
+ (base32 "18s2pwm45mzgm0rfw3wf0m349p6381i6iwbylxypizqcsvgwxb3f"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; No test suite